Kwalitee Issues

has_meta_yml

Add a META.yml to the distribution. Your buildtool should be able to autogenerate it.

package_version_matches_dist_version

Fix the version(s).

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Carp
  • strict
  • vars
  • warnings

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.02,0.05

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

has_tests_in_t_dir

Add tests or move tests.pl to the t/ directory!

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • Test::More
  • strict
  • warnings

Modules

Name Abstract Version View
Chipcard::PCSC Smart card reader interface library 0.05 metacpan
Chipcard::PCSC::Card 0.02 metacpan

Other Files

Card/Makefile.PL metacpan
MANIFEST metacpan
Makefile.PL metacpan
README metacpan