Kwalitee Issues

prereq_matches_use

List all used modules in META.yml requires

Error:

  • CPANPLUS::Backend
  • CPANPLUS::Configure
  • CPANPLUS::Error
  • CPANPLUS::Internals::Constants
  • CPANPLUS::Internals::Utils

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • Pod::Coverage::TrustPod
  • Test::Pod
  • Test::Pod::Coverage

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

Modules

Name Abstract Version View
App::SmokeBrew The guts of smokebrew 0.48 metacpan
App::SmokeBrew::BuildPerl build and install a particular version of Perl 0.48 metacpan
App::SmokeBrew::IniFile Parse the smokebrew configuration file 0.48 metacpan
App::SmokeBrew::PerlVersion Moose role for perl versions 0.48 metacpan
App::SmokeBrew::Plugin A Moose role for smokebrew plugins 0.48 metacpan
App::SmokeBrew::Plugin::CPANPLUS::YACSmoke A smokebrew plugin for CPANPLUS::YACSmoke based smokers 0.48 metacpan
App::SmokeBrew::Plugin::Null A smokebrew plugin for does nothing. 0.48 metacpan
App::SmokeBrew::Tools Various utility functions for smokebrew 0.48 metacpan
App::SmokeBrew::Types Moose types for smokebrew 0.48 metacpan
smokebrew Automated Perl building and installation for CPAN Testers 0.48 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan
dist.ini metacpan