Kwalitee Issues

has_readme

Add a README to the distribution. It should contain a quick description of your module and how to install it.

no_pax_headers

If you use Mac OS X >= 10.6, use gnu tar (/usr/bin/gnutar) to avoid PAX headers. It's also important to rename (shorten) long file names (>= 100 characters) in the distribution.

Error: PaxHeader/Sub-Current-0.03,PaxHeader/Sub-Current-0.03,Sub-Current-0.03/PaxHeader/Changes,Sub-Current-0.03/PaxHeader/Changes,Sub-Current-0.03/PaxHeader/Current.xs,Sub-Current-0.03/PaxHeader/Current.xs,Sub-Current-0.03/PaxHeader/lib,Sub-Current-0.03/PaxHeader/lib,Sub-Current-0.03/PaxHeader/Makefile.PL,Sub-Current-0.03/PaxHeader/Makefile.PL,Sub-Current-0.03/PaxHeader/MANIFEST,Sub-Current-0.03/PaxHeader/MANIFEST,Sub-Current-0.03/PaxHeader/META.json,Sub-Current-0.03/PaxHeader/META.json,Sub-Current-0.03/PaxHeader/META.yml,Sub-Current-0.03/PaxHeader/META.yml,Sub-Current-0.03/PaxHeader/t,Sub-Current-0.03/PaxHeader/t,Sub-Current-0.03/t/PaxHeader/01basic.t,Sub-Current-0.03/t/PaxHeader/01basic.t,Sub-Current-0.03/t/PaxHeader/02specialblocks.t,Sub-Current-0.03/t/PaxHeader/02specialblocks.t,Sub-Current-0.03/t/PaxHeader/03autoload.t,Sub-Current-0.03/t/PaxHeader/03autoload.t,Sub-Current-0.03/t/PaxHeader/04maincv.t,Sub-Current-0.03/t/PaxHeader/04maincv.t,Sub-Current-0.03/t/PaxHeader/05proto.t,Sub-Current-0.03/t/PaxHeader/05proto.t,Sub-Current-0.03/t/PaxHeader/06eval.t,Sub-Current-0.03/t/PaxHeader/06eval.t,Sub-Current-0.03/t/PaxHeader/07recurse.t,Sub-Current-0.03/t/PaxHeader/07recurse.t,Sub-Current-0.03/t/PaxHeader/08anon.t,Sub-Current-0.03/t/PaxHeader/08anon.t,Sub-Current-0.03/t/PaxHeader/50pod.t,Sub-Current-0.03/t/PaxHeader/50pod.t,Sub-Current-0.03/lib/PaxHeader/Sub,Sub-Current-0.03/lib/PaxHeader/Sub,Sub-Current-0.03/lib/Sub/PaxHeader/Current.pm,Sub-Current-0.03/lib/Sub/PaxHeader/Current.pm

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: Sub::Current

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Sub::Current

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

Modules

Name Abstract Version View
Sub::Current Get the current subroutine 0.03 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan