Kwalitee Issues

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: *** ERROR: Non-ASCII character seen before =encoding in 'façade'. Assuming ISO8859-1 at line 106 in file DBIx-DataModel-1.09/lib/DBIx/DataModel/Doc/Design.pod *** ERROR: unresolved internal link 'select' at line 104 in file DBIx-DataModel-1.09/lib/DBIx/DataModel/Doc/Design.pod *** ERROR: unresolved internal link 'bind' at line 324 in file DBIx-DataModel-1.09/lib/DBIx/DataModel/Doc/Design.pod *** ERROR: unresolved internal link 'status' at line 340 in file DBIx-DataModel-1.09/lib/DBIx/DataModel/Doc/Design.pod *** ERROR: unresolved internal link 'refine' at line 352 in file DBIx-DataModel-1.09/lib/DBIx/DataModel/Doc/Design.pod *** ERROR: unresolved internal link 'bind' at line 352 in file DBIx-DataModel-1.09/lib/DBIx/DataModel/Doc/Design.pod *** ERROR: unresolved internal link 'refine' at line 359 in file DBIx-DataModel-1.09/lib/DBIx/DataModel/Doc/Design.pod *** ERROR: unresolved internal link 'bind' at line 359 in file DBIx-DataModel-1.09/lib/DBIx/DataModel/Doc/Design.pod *** ERROR: unresolved internal link 'AutoExpand' at line 218 in file DBIx-DataModel-1.09/lib/DBIx/DataModel/Doc/Quickstart.pod *** ERROR: unresolved internal link 'Transactions and error handling' at line 965 in file DBIx-DataModel-1.09/lib/DBIx/DataModel/Doc/Reference.pod *** ERROR: unresolved internal link '_singleInsert' at line 1674 in file DBIx-DataModel-1.09/lib/DBIx/DataModel/Doc/Reference.pod *** ERROR: unresolved internal link '_singleInsert' at line 1683 in file DBIx-DataModel-1.09/lib/DBIx/DataModel/Doc/Reference.pod *** ERROR: unresolved internal link 'Schemae' at line 1923 in file DBIx-DataModel-1.09/lib/DBIx/DataModel/Doc/Reference.pod *** ERROR: Non-ASCII character seen before =encoding in 'N°'. Assuming ISO8859-1 at line 93 in file DBIx-DataModel-1.09/lib/DBIx/DataModel/Statement/JDBC.pm

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: DBIx::DataModel::Statement::JDBC

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: DBIx::DataModel::Statement::JDBC

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
DBIx::DataModel Classes and UML-style Associations on top of DBI 1.09 metacpan
DBIx::DataModel::Base Base class for DBIx::DataModel metacpan
DBIx::DataModel::Schema Factory for DBIx::DataModel Schemas metacpan
DBIx::DataModel::Schema::Generator automatically generate a schema for DBIx::DataModel metacpan
DBIx::DataModel::Source Abstract parent for Table and View metacpan
DBIx::DataModel::Statement DBIx::DataModel statement objects metacpan
DBIx::DataModel::Statement::JDBC Statement for interacting with DBD::JDBC metacpan
DBIx::DataModel::Table Parent for Table classes metacpan
DBIx::DataModel::View Parent for View classes metacpan

Other Files

Build.PL metacpan
Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan