Kwalitee Issues

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: SPVM-0.0284/lib/SPVM/Core/Document/Functions.pod -- Around line 34: Non-ASCII character seen before =encoding in 'SPVM::new_byte_array_string("‚ ‚¢‚¤‚¦‚¨");'. Assuming ISO8859-1 SPVM-0.0284/lib/SPVM/Math.pm -- Around line 115: You forgot a '=back' before '=head2'

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: SPVM::Arrays, SPVM::Byte, SPVM::Core::Object, SPVM::Core::Object::Array, SPVM::Core::Object::Array::Byte, SPVM::Core::Object::Array::Double, SPVM::Core::Object::Array::Float, SPVM::Core::Object::Array::Int, SPVM::Core::Object::Array::Long, SPVM::Core::Object::Array::Object, SPVM::Core::Object::Array::Short, SPVM::Core::Object::Package, SPVM::Core::Object::Package::String, SPVM::Debug, SPVM::Double, SPVM::Float, SPVM::Integer, SPVM::Long, SPVM::Math, SPVM::Short, SPVM::String, SPVM::std

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: SPVM::Arrays, SPVM::Byte, SPVM::Core::Object, SPVM::Core::Object::Array, SPVM::Core::Object::Array::Byte, SPVM::Core::Object::Array::Double, SPVM::Core::Object::Array::Float, SPVM::Core::Object::Array::Int, SPVM::Core::Object::Array::Long, SPVM::Core::Object::Array::Object, SPVM::Core::Object::Array::Short, SPVM::Core::Object::Package, SPVM::Core::Object::Package::String, SPVM::Debug, SPVM::Double, SPVM::Float, SPVM::Integer, SPVM::Long, SPVM::Math, SPVM::Short, SPVM::String, SPVM::std

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
SPVM Fast Calculation and Easy C/C++ Binding with perlish syntax and static typing 0.0284 metacpan
SPVM::Arrays Array Utility metacpan
SPVM::Build metacpan
SPVM::Byte Byte Utility metacpan
SPVM::Core::Object object metacpan
SPVM::Core::Object::Array Array object metacpan
SPVM::Core::Object::Array::Byte Byte Array Object metacpan
SPVM::Core::Object::Array::Double Double Array Object metacpan
SPVM::Core::Object::Array::Float Float Array Object metacpan
SPVM::Core::Object::Array::Int Int Array Object metacpan
SPVM::Core::Object::Array::Long Long Array Object metacpan
SPVM::Core::Object::Array::Object Object Array Object metacpan
SPVM::Core::Object::Array::Short Short Array Object metacpan
SPVM::Core::Object::Package Packaged based object metacpan
SPVM::Core::Object::Package::String String Object metacpan
SPVM::Debug Turn on debug mode metacpan
SPVM::Double Double Utility metacpan
SPVM::Float Float Utility metacpan
SPVM::Integer Integer Utility metacpan
SPVM::Long Long Utility metacpan
SPVM::Math Math Library metacpan
SPVM::Short Short Utility metacpan
SPVM::std Default Libraray metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README.pod metacpan