Kwalitee Issues

has_changelog

Add a Changelog (best named 'Changes') to the distribution. It should list at least major changes implemented in newer versions.

has_human_readable_license

Add a section called "LICENSE" to the documentation, or add a file named LICENSE to the distribution.

has_license_in_source_file

Add =head1 LICENSE and the text of the license to the main module in your code.

has_meta_yml

Add a META.yml to the distribution. Your buildtool should be able to autogenerate it.

has_proper_version

Remove all letters from the version number. If you want to mark a release as a developer release, use the scheme 'Module-1.00_01'

has_tests

Add tests!

main_module_version_matches_dist_version

Make sure that the main module name and version are the same of the distribution.

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: CGI.pm-2.37018/CGI/Apache .pm -- Around line 101: Non-ASCII character seen before =encoding in 'König'. Assuming CP1252 CGI.pm-2.37018/CGI/Switch .pm -- Around line 69: Non-ASCII character seen before =encoding in 'König'. Assuming CP1252 CGI.pm-2.37018/CGI.pm -- Around line 4072: Expected text after =item, not a number Around line 4076: Expected text after =item, not a number Around line 4080: Expected text after =item, not a number Around line 4393: Expected text after =item, not a number Around line 4397: Expected text after =item, not a number Around line 4402: Expected text after =item, not a number Around line 4407: Expected text after =item, not a number Around line 4500: Expected text after =item, not a number Around line 4504: Expected text after =item, not a number Around line 4516: Expected text after =item, not a number Around line 4521: Expected text after =item, not a number Around line 4672: Expected text after =item, not a number Around line 4678: Expected text after =item, not a number Around line 4687: Expected text after =item, not a number Around line 4691: Expected text after =item, not a number Around line 4697: Expected text after =item, not a number Around line 4741: Expected text after =item, not a number Around line 4749: Expected text after =item, not a number Around line 4756: Expected text after =item, not a number Around line 4762: Expected text after =item, not a number Around line 4769: Expected text after =item, not a number Around line 4824: Expected text after =item, not a number Around line 4830: Expected text after =item, not a number Around line 4835: Expected text after =item, not a number Around line 4841: Expected text after =item, not a number Around line 4883: Expected text after =item, not a number Around line 4887: Expected text after =item, not a number Around line 4895: Expected text after =item, not a number Around line 4902: Expected text after =item, not a number Around line 4907: Expected text after =item, not a number Around line 4914: Expected text after =item, not a number Around line 4962: Expected text after =item, not a number Around line 4970: Expected text after =item, not a number Around line 5018: Expected text after =item, not a number Around line 5023: Expected text after =item, not a number Around line 5064: Expected text after =item, not a number Around line 5069: Expected text after =item, not a number

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Apache
  • FCGI

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: CGI, CGI::Apache, CGI::Carp, CGI::Cookie, CGI::Fast, CGI::Push

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.06,1.01,1.03,1.08,1.1,2.37018

has_known_license_in_source_file

Add =head1 LICENSE and/or the proper text of the well-known license to the main module in your code.

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

has_tests_in_t_dir

Add tests or move tests.pl to the t/ directory!

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

no_invalid_versions

Fix the version numbers so that version::is_lax($version) returns true.

Error:

  • CGI/Fast.pm: HASH(0x85da840)

use_warnings

Add 'use warnings' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: CGI, CGI::Apache, CGI::Carp, CGI::Cookie, CGI::Fast, CGI::Push, CGI::Switch

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

Modules

Name Abstract Version View
CGI Simple Common Gateway Interface Class 2.37018 metacpan
CGI::Apache Make things work with CGI.pm against Perl-Apache API 1.1 metacpan
CGI::Carp CGI routines for writing to the HTTPD (or other) error log 1.08 metacpan
CGI::Cookie Interface to Netscape Cookies 1.03 metacpan
CGI::Fast CGI Interface for Fast CGI metacpan
CGI::Push Simple Interface to Server Push 1.01 metacpan
CGI::Switch Try more than one constructors and return the first object available 0.06 metacpan

Provides

Name File View
CGI::Apache::MultipartBuffer CGI/Apache.pm metacpan
Fh CGI.pm metacpan
MultipartBuffer CGI.pm metacpan
TempFile CGI.pm metacpan

Other Files

MANIFEST metacpan
Makefile.PL metacpan
README metacpan