Kwalitee Issues

has_changelog

Add a Changelog (best named 'Changes') to the distribution. It should list at least major changes implemented in newer versions.

has_meta_yml

Add a META.yml to the distribution. Your buildtool should be able to autogenerate it.

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Digest::SHA

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.24,1.2

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

no_unauthorized_packages

Ask the owner of the distribution (the one who released it first, or the one who is designated in x_authority) to give you a (co-)maintainer's permission.

Error:

  • Bloom::Filter

Modules

Name Abstract Version View
Bio::Kmer Helper module for Kmer Analysis. 0.24 metacpan
Bio::Kmer::BloomFilter 1.2 metacpan

Provides

Name File View
Bloom::Filter lib/Bio/Kmer/Bloom--Filter.pm metacpan

Other Files

MANIFEST metacpan
Makefile.PL metacpan
README metacpan
README.pod metacpan