Kwalitee Issues

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: ExtUtils::Install, ExtUtils::Liblist, ExtUtils::MM_BeOS, ExtUtils::MM_MacOS, ExtUtils::MM_Win95, ExtUtils::MakeMaker::bytes, ExtUtils::MakeMaker::vmsish, ExtUtils::Mkbootstrap, ExtUtils::testlib

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.01,0.02,0.04,0.05,0.08,0.11,1.01,1.05,1.08,1.09,1.11,1.15,1.19,1.3,1.33,1.45,1.47_01,2.08,5.72,6.26_01

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

no_unauthorized_packages

Ask the owner of the distribution (the one who released it first, or the one who is designated in x_authority) to give you a (co-)maintainer's permission.

Error:

  • DynaLoader

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: ExtUtils::Command, ExtUtils::Command::MM, ExtUtils::Install, ExtUtils::Installed, ExtUtils::Liblist, ExtUtils::Liblist::Kid, ExtUtils::MM, ExtUtils::MM_AIX, ExtUtils::MM_Any, ExtUtils::MM_BeOS, ExtUtils::MM_Cygwin, ExtUtils::MM_DOS, ExtUtils::MM_MacOS, ExtUtils::MM_NW5, ExtUtils::MM_OS2, ExtUtils::MM_QNX, ExtUtils::MM_UWIN, ExtUtils::MM_Unix, ExtUtils::MM_VMS, ExtUtils::MM_VOS, ExtUtils::MM_Win32, ExtUtils::MM_Win95, ExtUtils::MY, ExtUtils::MakeMaker, ExtUtils::MakeMaker::Config, ExtUtils::MakeMaker::bytes, ExtUtils::MakeMaker::vmsish, ExtUtils::Manifest, ExtUtils::Mkbootstrap, ExtUtils::Mksymlists, ExtUtils::Packlist, ExtUtils::testlib

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
ExtUtils::Command utilities to replace common UNIX commands in Makefiles etc. 1.09 metacpan
ExtUtils::Command::MM Commands for the MM's to use in Makefiles 0.05 metacpan
ExtUtils::Install install files from here to there 1.33 metacpan
ExtUtils::Installed Inventory management of installed modules 0.08 metacpan
ExtUtils::Liblist determine libraries to use and how to use them 1.01 metacpan
ExtUtils::Liblist::Kid 1.3 metacpan
ExtUtils::MM OS adjusted ExtUtils::MakeMaker subclass 0.05 metacpan
ExtUtils::MM_AIX AIX specific subclass of ExtUtils::MM_Unix 0.02 metacpan
ExtUtils::MM_Any Platform-agnostic MM methods 0.11 metacpan
ExtUtils::MM_BeOS methods to override UN*X behaviour in ExtUtils::MakeMaker 1.05 metacpan
ExtUtils::MM_Cygwin methods to override UN*X behaviour in ExtUtils::MakeMaker 1.08 metacpan
ExtUtils::MM_DOS DOS specific subclass of ExtUtils::MM_Unix 0.02 metacpan
ExtUtils::MM_MacOS once produced Makefiles for MacOS Classic 1.08 metacpan
ExtUtils::MM_NW5 methods to override UN*X behaviour in ExtUtils::MakeMaker 2.08 metacpan
ExtUtils::MM_OS2 methods to override UN*X behaviour in ExtUtils::MakeMaker 1.05 metacpan
ExtUtils::MM_QNX QNX specific subclass of ExtUtils::MM_Unix 0.02 metacpan
ExtUtils::MM_UWIN U/WIN specific subclass of ExtUtils::MM_Unix 0.02 metacpan
ExtUtils::MM_Unix methods used by ExtUtils::MakeMaker 1.47_01 metacpan
ExtUtils::MM_VMS methods to override UN*X behaviour in ExtUtils::MakeMaker 5.72 metacpan
ExtUtils::MM_VOS VOS specific subclass of ExtUtils::MM_Unix 0.02 metacpan
ExtUtils::MM_Win32 methods to override UN*X behaviour in ExtUtils::MakeMaker 1.11 metacpan
ExtUtils::MM_Win95 method to customize MakeMaker for Win9X 0.04 metacpan
ExtUtils::MY ExtUtils::MakeMaker subclass for customization 0.01 metacpan
ExtUtils::MakeMaker Create a module Makefile 6.26_01 metacpan
ExtUtils::MakeMaker::Config Wrapper around Config.pm 0.02 metacpan
ExtUtils::MakeMaker::bytes Version-agnostic bytes.pm 0.01 metacpan
ExtUtils::MakeMaker::vmsish Platform-agnostic vmsish.pm 0.01 metacpan
ExtUtils::Manifest utilities to write and check a MANIFEST file 1.45 metacpan
ExtUtils::Mkbootstrap make a bootstrap file for use by DynaLoader 1.15 metacpan
ExtUtils::Mksymlists write linker options files for dynamic extension 1.19 metacpan
ExtUtils::Packlist manage .packlist files 0.04 metacpan
ExtUtils::testlib add blib/* directories to @INC 1.15 metacpan

Provides

Name File View
DynaLoader lib/ExtUtils/Mkbootstrap.pm metacpan
ExtUtils::Install::Warn lib/ExtUtils/Install.pm metacpan
ExtUtils::MakeMaker::_version lib/ExtUtils/MM_Unix.pm metacpan
MM lib/ExtUtils/MM.pm metacpan
MY lib/ExtUtils/MY.pm metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan