Kwalitee Issues

has_meta_yml

Add a META.yml to the distribution. Your buildtool should be able to autogenerate it.

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Package::Stash::XS

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: Pcore::App::Controller::Ext, Pcore::Ext, Pcore::Ext::App, Pcore::Ext::App::Class, Pcore::Ext::App::Class::Ctx, Pcore::Ext::App::Class::Ctx::Class, Pcore::Ext::App::Class::Ctx::Func, Pcore::Ext::App::Class::Ctx::L10N, Pcore::Ext::App::Class::Ctx::Raw, Pcore::Ext::App::Class::Ctx::Type, Pcore::Ext::App::Class::TiedResolver, Pcore::Ext::Lib::core::Viewport, Pcore::Ext::Lib::modern::AmCharts4, Pcore::Ext::Lib::modern::Link, Pcore::Ext::Lib::modern::PDF, Pcore::Ext::Lib::modern::Plugin, Pcore::Ext::Overrides::classic, Pcore::Ext::Overrides::core, Pcore::Ext::Overrides::modern

has_known_license_in_source_file

Add =head1 LICENSE and/or the proper text of the well-known license to the main module in your code.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

use_warnings

Add 'use warnings' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Pcore::App::Controller::Ext, Pcore::Ext, Pcore::Ext::App, Pcore::Ext::App::Class, Pcore::Ext::App::Class::Ctx, Pcore::Ext::App::Class::Ctx::Class, Pcore::Ext::App::Class::Ctx::Func, Pcore::Ext::App::Class::Ctx::L10N, Pcore::Ext::App::Class::Ctx::Raw, Pcore::Ext::App::Class::Ctx::Type, Pcore::Ext::App::Class::TiedResolver, Pcore::Ext::Lib::core::Viewport, Pcore::Ext::Lib::modern::AmCharts4, Pcore::Ext::Lib::modern::Link, Pcore::Ext::Lib::modern::PDF, Pcore::Ext::Lib::modern::Plugin, Pcore::Ext::Overrides::classic, Pcore::Ext::Overrides::core, Pcore::Ext::Overrides::modern

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

Modules

Name Abstract Version View
Pcore::App::Controller::Ext ExtJS application HTTP controller metacpan
Pcore::Ext 0.019012 metacpan
Pcore::Ext::App metacpan
Pcore::Ext::App::Class metacpan
Pcore::Ext::App::Class::Ctx metacpan
Pcore::Ext::App::Class::Ctx::Class metacpan
Pcore::Ext::App::Class::Ctx::Func ExtJS function generator metacpan
Pcore::Ext::App::Class::Ctx::L10N ExtJS function call generator metacpan
Pcore::Ext::App::Class::Ctx::Raw ExtJS raw js generator metacpan
Pcore::Ext::App::Class::Ctx::Type metacpan
Pcore::Ext::App::Class::TiedResolver metacpan
Pcore::Ext::Lib::core::Viewport metacpan
Pcore::Ext::Lib::modern::AmCharts4 metacpan
Pcore::Ext::Lib::modern::Link metacpan
Pcore::Ext::Lib::modern::PDF metacpan
Pcore::Ext::Lib::modern::Plugin metacpan
Pcore::Ext::Overrides::classic metacpan
Pcore::Ext::Overrides::core metacpan
Pcore::Ext::Overrides::modern metacpan

Other Files

Build.PL metacpan
MANIFEST metacpan
META.json metacpan
README.md metacpan
cpanfile metacpan
lib/Build.PL metacpan