Kwalitee Issues

has_meta_yml

Add a META.yml to the distribution. Your buildtool should be able to autogenerate it.

manifest_matches_dist

Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.

Error:

  • MANIFEST (7) does not match dist (22):
  • Missing in MANIFEST: Auth/Auth.pm, Auth/Makefile.PL, Auth/RCS/Auth.pm,v, Auth/RCS/Makefile.PL,v, Auth/RCS/Makefile.old,v, Auth/RCS/test.pl,v, Auth/test.pl, RCS/AuthenSecurID.pm,v, RCS/Changes,v, RCS/MANIFEST,v, RCS/Makefile.PL,v, RCS/Makefile.old,v, RCS/README,v, RCS/ace_initd,v, RCS/test.pl,v

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: Apache-AuthenSecurID-0.4/Auth/Auth.pm -- Around line 571: '=item' outside of any '=over'Around line 627: You forgot a '=back' before '=head1'Around line 653: '=item' outside of any '=over'Around line 665: You forgot a '=back' before '=head1' Apache-AuthenSecurID-0.4/AuthenSecurID.pm -- Around line 115: '=item' outside of any '=over'Around line 160: You forgot a '=back' before '=head1'Around line 182: '=item' outside of any '=over'Around line 191: You forgot a '=back' before '=head1'

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Apache
  • Apache::Constants
  • Apache::Cookie
  • Apache::Log
  • Apache::Registry
  • Crypt::CBC

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

has_tests_in_t_dir

Add tests or move tests.pl to the t/ directory!

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Apache::AuthenSecurID, Apache::AuthenSecurID::Auth

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

Modules

Name Abstract Version View
Apache::AuthenSecurID Authentication via a SecurID server 0.4 metacpan

Other Files

Auth/Makefile.PL metacpan
Changes metacpan
MANIFEST metacpan
Makefile.PL metacpan
README metacpan