Kwalitee Issues

meta_yml_conforms_to_known_spec

Take a look at the META.yml Spec at http://module-build.sourceforge.net/META-spec-v1.4.html (for version 1.4) or http://search.cpan.org/perldoc?CPAN::Meta::Spec (for version 2), and change your META.yml accordingly.

Error: License '<undef>' is invalid (license) [Validation: 1.2];Missing mandatory field, 'abstract' (abstract) [Validation: 1.2];Missing mandatory field, 'license' (license) [Validation: 1.2];value is an undefined string (abstract) [Validation: 1.2]

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: Apache2-PageKit-2.15/lib/Apache2/PageKit.pm -- Around line 318: =pod directives shouldn't be over one line long! Ignoring all 7 lines of contentAround line 1626: Non-ASCII character seen before =encoding in 'Kerhervé'. Assuming CP1252

prereq_matches_use

List all used modules in META.yml requires

Error:

  • APR::Request::Param
  • Apache2::Cookie
  • Apache2::Request
  • Apache::Session
  • HTML::Entities
  • HTML::Parser
  • Mail::Mailer

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 1.50,2.15

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

no_unauthorized_packages

Ask the owner of the distribution (the one who released it first, or the one who is designated in x_authority) to give you a (co-)maintainer's permission.

Error:

  • MyPageKit::Common
  • MyPageKit::MyModel

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Apache2::ErrorReport, Apache2::PageKit, Apache2::PageKit::Config, Apache2::PageKit::Content, Apache2::PageKit::Edit, Apache2::PageKit::Model, Apache2::PageKit::Param, Apache2::PageKit::Session, Apache2::PageKit::View

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • Apache::TestRequest

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Apache2::ErrorReport Error Reporting under mod_perl metacpan
Apache2::PageKit MVCC web framework using mod_perl, XML and HTML::Template 2.15 metacpan
Apache2::PageKit::Config metacpan
Apache2::PageKit::Content metacpan
Apache2::PageKit::Edit metacpan
Apache2::PageKit::Model Base Model Class metacpan
Apache2::PageKit::Param metacpan
Apache2::PageKit::Session Session Handling 1.50 metacpan
Apache2::PageKit::View metacpan

Provides

Name File View
Apache2::PageKit::View::TT2 lib/Apache2/PageKit/View.pm metacpan
Apache2::Request::PageKit lib/Apache2/PageKit.pm metacpan
MyPageKit::Common eg/Model/MyPageKit/Common.pm metacpan
MyPageKit::MyModel eg/Model/MyPageKit/MyModel.pm metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan