Kwalitee Issues


Take a look at the META.yml Spec at (for version 1.4) or (for version 2), and change your META.yml accordingly.

Error: License 'artistic2' is invalid (license) [Validation: 1.4]


Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: App-AutoCRUD-0.13/lib/App/AutoCRUD/ -- Around line 223: =over without closing =backAround line 279: =over without closing =back


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.


Name Abstract Version View
App::AutoCRUD A Plack application for browsing and editing databases 0.13 metacpan
App::AutoCRUD::ConfigDomain checking configuration data metacpan
App::AutoCRUD::Context Context information for handling a single request metacpan
App::AutoCRUD::Controller parent class for controllers metacpan
App::AutoCRUD::Controller::Gvascript metacpan
App::AutoCRUD::Controller::Home metacpan
App::AutoCRUD::Controller::Join Join controller metacpan
App::AutoCRUD::Controller::Schema metacpan
App::AutoCRUD::Controller::Static metacpan
App::AutoCRUD::Controller::Table Table controller metacpan
App::AutoCRUD::DataSource metacpan
App::AutoCRUD::View metacpan
App::AutoCRUD::View::Download metacpan
App::AutoCRUD::View::Dumper metacpan
App::AutoCRUD::View::Json metacpan
App::AutoCRUD::View::Plain metacpan
App::AutoCRUD::View::Redirect metacpan
App::AutoCRUD::View::TT metacpan
App::AutoCRUD::View::Tsv View for tab-separated values metacpan
App::AutoCRUD::View::Xlsx metacpan
App::AutoCRUD::View::Xml metacpan
App::AutoCRUD::View::Yaml metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan