Kwalitee Issues


Add =head1 LICENSE and the text of the license to the main module in your code.


Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 1.01,2.002,2.003


Add =head1 LICENSE and/or the proper text of the well-known license to the main module in your code.


If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.


Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Array::IntSpan::IP


Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.


Name Abstract Version View
Array::IntSpan Handles arrays of scalars or objects using integer ranges 2.003 metacpan
Array::IntSpan::Fields IntSpan array using integer fields as indices 2.002 metacpan
Array::IntSpan::IP a Module for arrays using IP addresses as indices 1.01 metacpan

Other Files

ChangeLog metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan
dist.ini metacpan