Kwalitee Issues


List all used modules in META.yml requires


  • Glib
  • Gtk2
  • UNIVERSAL::require


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.


Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.


Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).


Name Abstract Version View
BBS::Perm a BBS client based on vte 1.01 metacpan
BBS::Perm::Config wrap a BBS::Perm configuration file metacpan
BBS::Perm::Plugin::Feed a feed plugin for BBS::Perm metacpan
BBS::Perm::Plugin::IP render IP infomation for BBS::Perm metacpan
BBS::Perm::Plugin::URI render quickly URI submittal for BBS::Perm metacpan
BBS::Perm::Term a multi-terminals component based on Vte for BBS::Perm metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan
dist.ini metacpan