Catalyst-Plugin-Session-PSGI

Metadata

Analyzed metadata and errors of Catalyst-Plugin-Session-PSGI.

{
   "abstracts_in_pod" : {
      "Catalyst::Plugin::Session::PSGI" : "minimal configuration access to PSGI/Plack session (EXPERIMENTAL)",
      "Catalyst::Plugin::Session::Store::PSGI" : "Session plugin for access to PSGI/Plack session",
      "NOOP" : "unsupported"
   },
   "author" : "CHISEL",
   "buildfile_executable" : 0,
   "dir_lib" : "lib",
   "dir_t" : "t",
   "dirs_array" : [
      "lib",
      "lib/Catalyst",
      "lib/Catalyst/Plugin",
      "lib/Catalyst/Plugin/Session",
      "lib/Catalyst/Plugin/Session/Store",
      "lib/Catalyst/Plugin/Session/State",
      "t"
   ],
   "dist" : "Catalyst-Plugin-Session-PSGI",
   "dynamic_config" : 0,
   "error" : {
      "valid_signature" : "WARNING: This key is not certified with a trusted signature!\nPrimary key fingerprint: 2445 B76E D078 1E72 FA32  4236 8788 FBC5 3885 BB11\n"
   },
   "extension" : "tar.gz",
   "external_license_file" : "LICENSE",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_changelog" : "Changes",
   "file_dist_ini" : "dist.ini",
   "file_license" : "LICENSE",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_json" : "META.json",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README.mkdn,README",
   "file_signature" : "SIGNATURE",
   "files_array" : [
      "dist.ini",
      "README",
      "META.json",
      "Changes",
      "README.mkdn",
      "Makefile.PL",
      "META.yml",
      "SIGNATURE",
      "MANIFEST",
      "LICENSE",
      "lib/Catalyst/Plugin/Session/PSGI.pm",
      "lib/Catalyst/Plugin/Session/Store/PSGI.pm",
      "lib/Catalyst/Plugin/Session/State/PSGI.pm",
      "t/00-load.t",
      "t/release-no-tabs.t",
      "t/release-pod-coverage.t",
      "t/release-kwalitee.t",
      "t/release-pod-syntax.t"
   ],
   "files_hash" : {
      "Changes" : {
         "mtime" : 1362063610,
         "size" : 288
      },
      "LICENSE" : {
         "mtime" : 1362063610,
         "size" : 18350
      },
      "MANIFEST" : {
         "mtime" : 1362063610,
         "size" : 315
      },
      "META.json" : {
         "mtime" : 1362063610,
         "size" : 1551
      },
      "META.yml" : {
         "mtime" : 1362063610,
         "size" : 739
      },
      "Makefile.PL" : {
         "mtime" : 1362063610,
         "size" : 1154,
         "used" : [
            "ExtUtils::MakeMaker",
            "strict",
            "warnings"
         ]
      },
      "README" : {
         "mtime" : 1362063610,
         "size" : 3307
      },
      "README.mkdn" : {
         "mtime" : 1362063610,
         "size" : 3742
      },
      "SIGNATURE" : {
         "mtime" : 1362063610,
         "size" : 1810
      },
      "dist.ini" : {
         "mtime" : 1362063610,
         "size" : 887
      },
      "lib/Catalyst/Plugin/Session/PSGI.pm" : {
         "license" : "Perl_5",
         "module" : "Catalyst::Plugin::Session::PSGI",
         "mtime" : 1362063610,
         "size" : 3565,
         "used" : [
            "strict",
            "warnings"
         ]
      },
      "lib/Catalyst/Plugin/Session/State/PSGI.pm" : {
         "license" : "Perl_5",
         "module" : "Catalyst::Plugin::Session::State::PSGI",
         "mtime" : 1362063610,
         "size" : 2639,
         "used" : [
            "Catalyst::Plugin::Session::PSGI",
            "Catalyst::Plugin::Session::State",
            "strict",
            "warnings"
         ]
      },
      "lib/Catalyst/Plugin/Session/Store/PSGI.pm" : {
         "license" : "Perl_5",
         "module" : "Catalyst::Plugin::Session::Store::PSGI",
         "mtime" : 1362063610,
         "size" : 2854,
         "used" : [
            "Catalyst::Plugin::Session::PSGI",
            "Catalyst::Plugin::Session::Store",
            "strict",
            "warnings"
         ]
      },
      "t/00-load.t" : {
         "mtime" : 1362063610,
         "size" : 63,
         "used" : [
            "Test::UseAllModules",
            "strict"
         ]
      },
      "t/release-kwalitee.t" : {
         "mtime" : 1362063610,
         "required" : [
            "Test::More"
         ],
         "size" : 399,
         "used" : [
            "Test::More",
            "strict",
            "warnings"
         ],
         "used_in_eval" : [
            "Test::Kwalitee"
         ]
      },
      "t/release-no-tabs.t" : {
         "mtime" : 1362063610,
         "required" : [
            "Test::More"
         ],
         "size" : 296,
         "used" : [
            "Test::More",
            "strict",
            "warnings"
         ],
         "used_in_eval" : [
            "Test::NoTabs"
         ]
      },
      "t/release-pod-coverage.t" : {
         "mtime" : 1362063610,
         "required" : [
            "Test::More"
         ],
         "size" : 501,
         "used" : [
            "Test::More"
         ],
         "used_in_eval" : [
            "Pod::Coverage::TrustPod",
            "Test::Pod::Coverage"
         ]
      },
      "t/release-pod-syntax.t" : {
         "mtime" : 1362063610,
         "required" : [
            "Test::More"
         ],
         "size" : 296,
         "used" : [
            "Test::More"
         ],
         "used_in_eval" : [
            "Test::Pod"
         ]
      }
   },
   "got_prereq_from" : "META.yml",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "distname_matches_name_in_meta" : 1,
      "easily_repackageable_by_debian" : 1,
      "easily_repackageable_by_fedora" : 1,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "fits_fedora_license" : 1,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 1,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 1,
      "kwalitee" : "97.62",
      "manifest_matches_dist" : 1,
      "metayml_conforms_to_known_spec" : 1,
      "metayml_declares_perl_version" : 0,
      "metayml_has_license" : 1,
      "metayml_has_provides" : 0,
      "metayml_has_repository_resource" : 1,
      "metayml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 1,
      "valid_signature" : 1
   },
   "latest_mtime" : 1362063610,
   "license" : "perl defined in META.yml defined in LICENSE",
   "license_file" : "lib/Catalyst/Plugin/Session/PSGI.pm,lib/Catalyst/Plugin/Session/State/PSGI.pm,lib/Catalyst/Plugin/Session/Store/PSGI.pm",
   "license_from_yaml" : "perl",
   "license_in_pod" : 1,
   "license_type" : "Perl_5",
   "licenses" : {
      "Perl_5" : [
         "lib/Catalyst/Plugin/Session/PSGI.pm",
         "lib/Catalyst/Plugin/Session/State/PSGI.pm",
         "lib/Catalyst/Plugin/Session/Store/PSGI.pm"
      ]
   },
   "manifest_matches_dist" : 1,
   "meta_yml" : {
      "abstract" : "minimal configuration access to PSGI/Plack session (EXPERIMENTAL)",
      "author" : [
         "Chisel <chisel@chizography.net>"
      ],
      "build_requires" : {
         "Test::UseAllModules" : "0"
      },
      "configure_requires" : {
         "ExtUtils::MakeMaker" : "6.30"
      },
      "dynamic_config" : "0",
      "generated_by" : "Dist::Zilla version 4.300029, CPAN::Meta::Converter version 2.120921",
      "license" : "perl",
      "meta-spec" : {
         "url" : "http://module-build.sourceforge.net/META-spec-v1.4.html",
         "version" : "1.4"
      },
      "name" : "Catalyst-Plugin-Session-PSGI",
      "requires" : {
         "Catalyst::Plugin::Session::State" : "0",
         "Catalyst::Plugin::Session::Store" : "0"
      },
      "resources" : {
         "bugtracker" : "http://rt.cpan.org/Public/Dist/Display.html?Name=Catalyst-Plugin-Session-PSGI",
         "repository" : "git://github.com/chiselwright/catalyst-plugin-session-psgi.git"
      },
      "version" : "0.0.2"
   },
   "metayml_is_parsable" : 1,
   "modules" : [
      {
         "file" : "lib/Catalyst/Plugin/Session/PSGI.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "Catalyst::Plugin::Session::PSGI"
      },
      {
         "file" : "lib/Catalyst/Plugin/Session/Store/PSGI.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "Catalyst::Plugin::Session::Store::PSGI"
      },
      {
         "file" : "lib/Catalyst/Plugin/Session/State/PSGI.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "Catalyst::Plugin::Session::State::PSGI"
      }
   ],
   "no_pax_headers" : 1,
   "package" : "Catalyst-Plugin-Session-PSGI-0.0.2.tar.gz",
   "prereq" : [
      {
         "is_build_prereq" : 1,
         "requires" : "Test::UseAllModules",
         "type" : "build_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Catalyst::Plugin::Session::Store",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "requires" : "ExtUtils::MakeMaker",
         "type" : "configure_requires",
         "version" : "6.30"
      },
      {
         "is_prereq" : 1,
         "requires" : "Catalyst::Plugin::Session::State",
         "type" : "runtime_requires",
         "version" : "0"
      }
   ],
   "released_epoch" : 1362063629,
   "size_packed" : 14051,
   "size_unpacked" : 42756,
   "uses" : {
      "required_in_tests" : {
         "Test::More" : 4
      },
      "used_in_code" : {
         "Catalyst::Plugin::Session::State" : 1,
         "Catalyst::Plugin::Session::Store" : 1,
         "strict" : 3,
         "warnings" : 3
      },
      "used_in_config" : {
         "ExtUtils::MakeMaker" : 1,
         "strict" : 1,
         "warnings" : 1
      },
      "used_in_eval_in_tests" : {
         "Pod::Coverage::TrustPod" : 1,
         "Test::Kwalitee" : 1,
         "Test::NoTabs" : 1,
         "Test::Pod" : 1,
         "Test::Pod::Coverage" : 1
      },
      "used_in_tests" : {
         "Test::More" : 4,
         "Test::UseAllModules" : 1,
         "strict" : 3,
         "warnings" : 2
      }
   },
   "valid_signature" : 0,
   "version" : "0.0.2",
   "versions" : {
      "lib/Catalyst/Plugin/Session/PSGI.pm" : {
         "Catalyst::Plugin::Session::PSGI" : "0.000002"
      },
      "lib/Catalyst/Plugin/Session/State/PSGI.pm" : {
         "Catalyst::Plugin::Session::State::PSGI" : "0.000002"
      },
      "lib/Catalyst/Plugin/Session/Store/PSGI.pm" : {
         "Catalyst::Plugin::Session::Store::PSGI" : "0.000002"
      }
   },
   "vname" : "Catalyst-Plugin-Session-PSGI-0.0.2"
}