Kwalitee Issues


Add a META.yml to the distribution. Your buildtool should be able to autogenerate it.


Add a README to the distribution. It should contain a quick description of your module and how to install it.


Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.


  • MANIFEST (37) does not match dist (39):
  • Missing in MANIFEST: .gitignore, MANIFEST


Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: Coat-Persistent-0.223/lib/Coat/Persistent/ -- Around line 126: '=item' outside of any '=over' Coat-Persistent-0.223/lib/Coat/ -- Around line 1252: =back without =overAround line 1254: '=item' outside of any '=over'


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.


Name Abstract Version View
Coat::Persistent Simple Object-Relational mapping for Coat objects 0.223 metacpan
Coat::Persistent::Constraint metacpan
Coat::Persistent::Meta meta-information for Coat::Persistent objects metacpan
Coat::Persistent::Object root object for Coat::Persistent models metacpan
Coat::Persistent::Types metacpan
Coat::Persistent::Types::MySQL Attribute types and coercions for MySQL data types metacpan

Other Files

MANIFEST metacpan
Makefile.PL metacpan