Under maintenance.

Most probably CPANTS databases are being regenerated from scratch due to major changes in Kwalitee metrics or updates of relevant modules/perl. Usually this maintenance takes about a day or two, and some of the information may be old or missing tentatively. Sorry for the inconvenience.

Kwalitee Issues

extracts_nicely

Pack the distribution with a proper command such as "make dist" and "./Build dist", or use a distribution builder such as Dist::Zilla, Dist::Milla, Minilla.

Error: More than one top directories are found: Config-Easy-0.3;._Config-Easy-0.3

has_human_readable_license

Add a section called "LICENSE" to the documentation, or add a file named LICENSE to the distribution.

has_license_in_source_file

Add =head1 LICENSE and the text of the license to the main module in your code.

manifest_matches_dist

Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.

Error: Cannot find MANIFEST in dist.

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: Config-Easy-0.3::lib::Config::._Easy, Config-Easy-0.3::t::._Mod, Mod

has_known_license_in_source_file

Add =head1 LICENSE and/or the proper text of the well-known license to the main module in your code.

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

no_dot_underscore_files

If you use Mac OS X, set COPYFILE_DISABLE (for OS 10.5 and better) or COPY_EXTENDED_ATTRIBUTES_DISABLE (for OS 10.4) environmental variable to true to exclude dot underscore files from a distribution.

Error:

  • ._Config-Easy-0.3
  • Config-Easy-0.3/._Changes
  • Config-Easy-0.3/._MANIFEST
  • Config-Easy-0.3/._META.yml
  • Config-Easy-0.3/._Makefile.PL
  • Config-Easy-0.3/._README
  • Config-Easy-0.3/._lib
  • Config-Easy-0.3/._t
  • Config-Easy-0.3/lib/._Config
  • Config-Easy-0.3/lib/Config/._Easy.pm
  • Config-Easy-0.3/t/._Mod.pm
  • Config-Easy-0.3/t/._conf
  • Config-Easy-0.3/t/._conf1
  • Config-Easy-0.3/t/._conf2
  • Config-Easy-0.3/t/._test.t
  • Config-Easy-0.3/t/._testargs.t
  • Config-Easy-0.3/t/._testargs2.t

proper_libs

Move your *.pm files in a directory named 'lib'. The directory structure should look like 'lib/Your/Module.pm' for a module named 'Your::Module'. If you need to provide additional files, e.g. for testing, that should not be considered for Kwalitee, then you should look at the 'provides' map in META.yml to limit the files scanned; or use the 'no_index' map to exclude parts of the distribution.

Error: Config-Easy-0.3/lib/Config/._Easy.pm, Config-Easy-0.3/t/._Mod.pm, Config-Easy-0.3/lib/Config/Easy.pm, Config-Easy-0.3/t/Mod.pm

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Config-Easy-0.3::lib::Config::._Easy, Config-Easy-0.3::t::._Mod, Config::Easy, Mod

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

Modules

Name Abstract Version View
Config::Easy Access to a simple key-value configuration file. 0.3 metacpan
Mod metacpan

Other Files

Config-Easy-0.3/MANIFEST metacpan
Config-Easy-0.3/META.yml metacpan
Config-Easy-0.3/Makefile.PL metacpan