Courriel

Prerequisites

Courriel declares the following 34 modules as prerequisites.

Listed PrerequisitesRequired VersionLatest DistKwalitee
Carp0Carp-1.3301125.71
DateTime0DateTime-1.10134.29
DateTime::Format::Mail0DateTime-Format-Mail-0.401131.43
DateTime::Format::Natural0DateTime-Format-Natural-1.02125.71
Devel::PartialDump0Devel-PartialDump-0.17134.29
Email::Abstract::Plugin0Email-Abstract-3.007128.57
Email::Address0Email-Address-1.905131.43
Email::MIME::Encodings0Email-MIME-Encodings-1.315131.43
Email::MessageID0Email-MessageID-1.405131.43
Encode0Encode-2.62125.71
Exporter0Exporter-5.70125.71
File::Basename0perl0.00
File::LibMagic0File-LibMagic-1.02134.29
File::Slurp::Tiny0File-Slurp-Tiny-0.003134.29
List::AllUtils0List-AllUtils-0.08131.43
List::MoreUtils0.28List-MoreUtils-0.33128.57
MIME::Base640MIME-Base64-3.14125.71
MIME::QuotedPrint0MIME-Base64-3.14125.71
Moose0Moose-2.1211134.29
Moose::Role0Moose-2.1211134.29
MooseX::Params::Validate0MooseX-Params-Validate-0.18131.43
MooseX::Role::Parameterized0MooseX-Role-Parameterized-1.08134.29
MooseX::StrictConstructor0MooseX-StrictConstructor-0.19131.43
MooseX::Types0MooseX-Types-0.44134.29
MooseX::Types::Combine0MooseX-Types-0.44134.29
MooseX::Types::Common::String0MooseX-Types-Common-0.001012134.29
MooseX::Types::Moose0MooseX-Types-0.44134.29
Scalar::Util0Scalar-List-Utils-1.39122.86
Sub::Exporter0Sub-Exporter-0.987131.43
namespace::autoclean0namespace-autoclean-0.19134.29
parent0parent-0.228120.00
perlv5.10.0perl0.00
strict0perl0.00
warnings0perl0.00

Courriel declares the following 9 modules as build prerequisites.

Listed Build PrerequisitesRequired VersionLatest DistKwalitee
ExtUtils::MakeMaker0ExtUtils-MakeMaker-6.98131.43
File::Spec0PathTools-3.47122.86
IO::Handle0IO-1.25125.71
IPC::Open30perl0.00
Test::Differences0Test-Differences-0.62125.71
Test::Fatal0Test-Fatal-0.013131.43
Test::More0.88Test-Simple-1.001003128.57
Test::Requires0Test-Requires-0.08134.29
utf80perl0.00

Courriel declares the following 1 modules as optional prerequisites.

Listed Optional PrerequisitesRequired VersionLatest DistKwalitee
ExtUtils::MakeMaker0ExtUtils-MakeMaker-6.98131.428571428571