Kwalitee Issues

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: Curses::UI::Container, Curses::UI::Language, Curses::UI::Language::chinese, Curses::UI::Language::czech, Curses::UI::Language::dutch, Curses::UI::Language::english, Curses::UI::Language::french, Curses::UI::Language::german, Curses::UI::Language::italian, Curses::UI::Language::japanese, Curses::UI::Language::norwegian, Curses::UI::Language::polish, Curses::UI::Language::portuguese, Curses::UI::Language::russian, Curses::UI::Language::slovak, Curses::UI::Language::spanish, Curses::UI::Language::turkish

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.01,0.9609,1.0,1.00,1.0001,1.0011,1.10,1.11,1.12,1.3,1.5

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

no_unauthorized_packages

Ask the owner of the distribution (the one who released it first, or the one who is designated in x_authority) to give you a (co-)maintainer's permission.

Error:

  • Curses::UI
  • Curses::UI::Buttonbox
  • Curses::UI::Calendar
  • Curses::UI::Checkbox
  • Curses::UI::Color
  • Curses::UI::Common
  • Curses::UI::Container
  • Curses::UI::ContainerWidget
  • Curses::UI::Dialog::Basic
  • Curses::UI::Dialog::Calendar
  • Curses::UI::Dialog::Dirbrowser
  • Curses::UI::Dialog::Error
  • Curses::UI::Dialog::Filebrowser
  • Curses::UI::Dialog::Progress
  • Curses::UI::Dialog::Question
  • Curses::UI::Dialog::Status
  • Curses::UI::Label
  • Curses::UI::Language
  • Curses::UI::Language::chinese
  • Curses::UI::Language::dutch
  • Curses::UI::Language::english
  • Curses::UI::Language::french
  • Curses::UI::Language::german
  • Curses::UI::Language::italian
  • Curses::UI::Language::norwegian
  • Curses::UI::Language::polish
  • Curses::UI::Language::portuguese
  • Curses::UI::Language::russian
  • Curses::UI::Language::spanish
  • Curses::UI::Language::turkish
  • Curses::UI::Listbox
  • Curses::UI::MenuListbox
  • Curses::UI::Menubar
  • Curses::UI::Notebook
  • Curses::UI::PasswordEntry
  • Curses::UI::Popupmenu
  • Curses::UI::PopupmenuListbox
  • Curses::UI::Progressbar
  • Curses::UI::Radiobuttonbox
  • Curses::UI::SearchEntry
  • Curses::UI::Searchable
  • Curses::UI::TextEditor
  • Curses::UI::TextEntry
  • Curses::UI::TextViewer
  • Curses::UI::Widget
  • Curses::UI::Window

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Curses::UI::Buttonbox, Curses::UI::Calendar, Curses::UI::Checkbox, Curses::UI::Color, Curses::UI::Common, Curses::UI::Container, Curses::UI::Dialog::Basic, Curses::UI::Dialog::Calendar, Curses::UI::Dialog::Dirbrowser, Curses::UI::Dialog::Error, Curses::UI::Dialog::Filebrowser, Curses::UI::Dialog::Progress, Curses::UI::Dialog::Question, Curses::UI::Dialog::Status, Curses::UI::Label, Curses::UI::Language, Curses::UI::Language::chinese, Curses::UI::Language::czech, Curses::UI::Language::dutch, Curses::UI::Language::english, Curses::UI::Language::french, Curses::UI::Language::german, Curses::UI::Language::italian, Curses::UI::Language::japanese, Curses::UI::Language::norwegian, Curses::UI::Language::polish, Curses::UI::Language::portuguese, Curses::UI::Language::russian, Curses::UI::Language::slovak, Curses::UI::Language::spanish, Curses::UI::Language::turkish, Curses::UI::Listbox, Curses::UI::Menubar, Curses::UI::PasswordEntry, Curses::UI::Popupmenu, Curses::UI::Progressbar, Curses::UI::Radiobuttonbox, Curses::UI::Searchable, Curses::UI::TextEditor, Curses::UI::TextEntry, Curses::UI::TextViewer, Curses::UI::Widget, Curses::UI::Window

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Curses::UI A curses based OO user interface framework 0.9609 metacpan
Curses::UI::Buttonbox Create and manipulate button widgets 1.10 metacpan
Curses::UI::Calendar Create and manipulate calendar widgets 1.10 metacpan
Curses::UI::Checkbox Create and manipulate checkbox widgets 1.11 metacpan
Curses::UI::Color Color support module 0.01 metacpan
Curses::UI::Common Common methods for Curses::UI 1.10 metacpan
Curses::UI::Container Create and manipulate container widgets 1.11 metacpan
Curses::UI::Dialog::Basic Create and manipulate basic dialogs 1.10 metacpan
Curses::UI::Dialog::Calendar Create and manipulate calendar dialogs 1.10 metacpan
Curses::UI::Dialog::Dirbrowser Create and manipulate filebrowser dialogs 1.0 metacpan
Curses::UI::Dialog::Error Create and manipulate error dialogs 1.10 metacpan
Curses::UI::Dialog::Filebrowser Create and manipulate filebrowser dialogs 1.10 metacpan
Curses::UI::Dialog::Progress Create and manipulate progress dialogs 1.10 metacpan
Curses::UI::Dialog::Question Pose a simple question to the user 1.00 metacpan
Curses::UI::Dialog::Status Create and manipulate status dialogs 1.10 metacpan
Curses::UI::Label Create and manipulate label widgets 1.11 metacpan
Curses::UI::Language metacpan
Curses::UI::Language::chinese metacpan
Curses::UI::Language::czech metacpan
Curses::UI::Language::dutch metacpan
Curses::UI::Language::english metacpan
Curses::UI::Language::french metacpan
Curses::UI::Language::german metacpan
Curses::UI::Language::italian metacpan
Curses::UI::Language::japanese metacpan
Curses::UI::Language::norwegian metacpan
Curses::UI::Language::polish metacpan
Curses::UI::Language::portuguese metacpan
Curses::UI::Language::russian metacpan
Curses::UI::Language::slovak metacpan
Curses::UI::Language::spanish metacpan
Curses::UI::Language::turkish metacpan
Curses::UI::Listbox Create and manipulate listbox widgets 1.3 metacpan
Curses::UI::Menubar Create and manipulate menubar widgets 1.10 metacpan
Curses::UI::Notebook Create and manipulate notebook widgets. 1.0001 metacpan
Curses::UI::PasswordEntry Create and manipulate passwordentry widgets 1.10 metacpan
Curses::UI::Popupmenu Create and manipulate popupbox widgets 1.0011 metacpan
Curses::UI::Progressbar Create and manipulate progressbar widgets 1.10 metacpan
Curses::UI::Radiobuttonbox Create and manipulate radiobuttonbox widgets 1.10 metacpan
Curses::UI::Searchable Add 'less'-like search abilities to a widget 1.10 metacpan
Curses::UI::TextEditor Create and manipulate texteditor widgets 1.5 metacpan
Curses::UI::TextEntry Create and manipulate textentry widgets 1.10 metacpan
Curses::UI::TextViewer Create and manipulate textviewer widgets 1.10 metacpan
Curses::UI::Widget The base class for all widgets 1.12 metacpan
Curses::UI::Window Create and manipulate Window widgets 1.10 metacpan

Provides

Name File View
Curses::UI::ContainerWidget lib/Curses/UI/Widget.pm metacpan
Curses::UI::MenuListbox lib/Curses/UI/Menubar.pm metacpan
Curses::UI::PopupmenuListbox lib/Curses/UI/Popupmenu.pm metacpan
Curses::UI::SearchEntry lib/Curses/UI/Searchable.pm metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan