Kwalitee Issues


Provide a short description in the NAME section of the pod (after the module name followed by a hyphen) at least for the main module of this distribution.


Add a Changelog (best named 'Changes') to the distribution. It should list at least major changes implemented in newer versions.


Add =head1 LICENSE and the text of the license to the main module in your code.


Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.


  • MANIFEST (67) does not match dist (68):
  • Missing in MANIFEST: Makefile


Take a look at the META.yml Spec at (for version 1.4) or (for version 2), and change your META.yml accordingly.

Error: '@XMLDOOM_VERSION' for 'version' is not a valid version. (version) [Validation: 1.0]


Upgrade the bundled version of Module::Install to at least 0.89, but preferably to the most current release. Alternatively, you can switch to another build system / installer that does not suffer from this problem. (ExtUtils::MakeMaker, Module::Build both of which have their own set of problems.)


Upgrade the bundled version of Module::Install to the most current release. Alternatively, you can switch to another build system / installer that does not suffer from this problem. (ExtUtils::MakeMaker, Module::Build both of which have their own set of problems.)


Remove the offending files/directories!

Error: Makefile


Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: DBIx::Romani, DBIx::Romani::Query::SQL::Column, DBIx::Romani::Query::SQL::Literal, DBIx::Romani::Query::SQL::Null, DBIx::Romani::Query::Variable


Add =head1 LICENSE and/or the proper text of the well-known license to the main module in your code.


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


Add tests or move to the t/ directory!


If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.


Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: DBIx::Romani, DBIx::Romani::Connection, DBIx::Romani::Connection::Base, DBIx::Romani::Connection::Factory, DBIx::Romani::Driver, DBIx::Romani::Driver::mysql, DBIx::Romani::Driver::mysql::IdGenerator, DBIx::Romani::Driver::sqlite, DBIx::Romani::Driver::sqlite::IdGenerator, DBIx::Romani::IdGenerator, DBIx::Romani::PreparedQuery, DBIx::Romani::PreparedStatement, DBIx::Romani::Query::Comparison, DBIx::Romani::Query::Delete, DBIx::Romani::Query::Function, DBIx::Romani::Query::Function::Count, DBIx::Romani::Query::Function::Now, DBIx::Romani::Query::Insert, DBIx::Romani::Query::Operator, DBIx::Romani::Query::SQL::Column, DBIx::Romani::Query::SQL::Generate, DBIx::Romani::Query::SQL::Literal, DBIx::Romani::Query::SQL::Null, DBIx::Romani::Query::SQL::TTT::Function, DBIx::Romani::Query::SQL::TTT::Join, DBIx::Romani::Query::SQL::TTT::Keyword, DBIx::Romani::Query::SQL::TTT::Operator, DBIx::Romani::Query::Select, DBIx::Romani::Query::Select::Join, DBIx::Romani::Query::Select::OrderBy, DBIx::Romani::Query::Select::Result, DBIx::Romani::Query::Update, DBIx::Romani::Query::Variable, DBIx::Romani::Query::Where, DBIx::Romani::Query::XML::Function, DBIx::Romani::Query::XML::SQL, DBIx::Romani::Query::XML::Select, DBIx::Romani::Query::XML::TTT, DBIx::Romani::Query::XML::Util, DBIx::Romani::Query::XML::Where, DBIx::Romani::ResultSet


Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.


Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).


Name Abstract Version View
DBIx::Romani 0.000016 metacpan
DBIx::Romani::Connection metacpan
DBIx::Romani::Connection::Base metacpan
DBIx::Romani::Connection::Factory metacpan
DBIx::Romani::Driver metacpan
DBIx::Romani::Driver::mysql metacpan
DBIx::Romani::Driver::mysql::IdGenerator metacpan
DBIx::Romani::Driver::sqlite metacpan
DBIx::Romani::Driver::sqlite::IdGenerator metacpan
DBIx::Romani::IdGenerator metacpan
DBIx::Romani::PreparedQuery metacpan
DBIx::Romani::PreparedStatement metacpan
DBIx::Romani::Query::Comparison metacpan
DBIx::Romani::Query::Delete metacpan
DBIx::Romani::Query::Function metacpan
DBIx::Romani::Query::Function::Count metacpan
DBIx::Romani::Query::Function::Now metacpan
DBIx::Romani::Query::Insert metacpan
DBIx::Romani::Query::Operator metacpan
DBIx::Romani::Query::SQL::Column metacpan
DBIx::Romani::Query::SQL::Generate metacpan
DBIx::Romani::Query::SQL::Literal metacpan
DBIx::Romani::Query::SQL::Null metacpan
DBIx::Romani::Query::SQL::TTT::Function metacpan
DBIx::Romani::Query::SQL::TTT::Join metacpan
DBIx::Romani::Query::SQL::TTT::Keyword metacpan
DBIx::Romani::Query::SQL::TTT::Operator metacpan
DBIx::Romani::Query::Select metacpan
DBIx::Romani::Query::Select::Join metacpan
DBIx::Romani::Query::Select::OrderBy metacpan
DBIx::Romani::Query::Select::Result metacpan
DBIx::Romani::Query::Update metacpan
DBIx::Romani::Query::Variable metacpan
DBIx::Romani::Query::Where metacpan
DBIx::Romani::Query::XML::Function metacpan
DBIx::Romani::Query::XML::SQL metacpan
DBIx::Romani::Query::XML::Select metacpan
DBIx::Romani::Query::XML::TTT metacpan
DBIx::Romani::Query::XML::Util metacpan
DBIx::Romani::Query::XML::Where metacpan
DBIx::Romani::ResultSet metacpan

Other Files

MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan