Kwalitee Issues

No Core Issues.


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.


This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.


Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.


Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).


Name Abstract Version View
Data::Grid Incremental read-only (for now) access to grid-based data 0.01_01 metacpan
Data::Grid::CSV CSV driver for Data::Grid 0.01_01 metacpan
Data::Grid::Cell Cell implementation for Data::Grid::Row 0.01_01 metacpan
Data::Grid::Container Generic superclass for Data::Grid containers 0.01_01 metacpan
Data::Grid::Excel Excel driver for Data::Grid 0.01_01 metacpan
Data::Grid::Excel::XLSX XML-based Excel driver for Data::Grid 0.01_01 metacpan
Data::Grid::Row Row implementation for Data::Grid::Table 0.01_01 metacpan
Data::Grid::Table A table implementation for Data::Grid 0.01_01 metacpan


Name File View
Data::Grid::CSV::Cell lib/Data/Grid/ metacpan
Data::Grid::CSV::Row lib/Data/Grid/ metacpan
Data::Grid::CSV::Table lib/Data/Grid/ metacpan
Data::Grid::Excel::Cell lib/Data/Grid/ metacpan
Data::Grid::Excel::Row lib/Data/Grid/ metacpan
Data::Grid::Excel::Table lib/Data/Grid/ metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan