Kwalitee Issues

No Core Issues.


If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.


This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.


Name Abstract Version View
Data::Keys get/set key+value extensible manipulations, base module for Data::Keys::E::* 0.03 metacpan
Data::Keys::E::Dir::Auto auto create folder when needed 0.03 metacpan
Data::Keys::E::Dir::Lock uses additional folder to lock files 0.03 metacpan
Data::Keys::E::Dir::LockInPlace place locks directly on the stored files 0.03 metacpan
Data::Keys::E::Key::Adapt change key with a callback 0.03 metacpan
Data::Keys::E::Key::Auto auto create key via callback 0.03 metacpan
Data::Keys::E::Key::AutoLock lock keys automatically 0.03 metacpan
Data::Keys::E::Locking get/set locking 0.03 metacpan
Data::Keys::E::Store::Dir folder storage 0.03 metacpan
Data::Keys::E::Store::Mem in memory storage 0.03 metacpan
Data::Keys::E::UniqSet a key can be set only once 0.03 metacpan
Data::Keys::E::Value::InfDef inflate/deflate values 0.03 metacpan

Other Files

Build.PL metacpan
Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
README metacpan