Dist-Zilla-Plugin-Subversion-NextVersion

Metadata

Analyzed metadata and errors of Dist-Zilla-Plugin-Subversion-NextVersion.

{
   "abstracts" : {
      "Dist::Zilla::Plugin::Subversion::NextVersion" : "provide a version number by bumping the last subversion release tag"
   },
   "author" : "BENNING",
   "buildfile_executable" : 0,
   "dir_lib" : "lib",
   "dir_t" : "t",
   "dirs_array" : [
      "lib",
      "lib/Dist",
      "lib/Dist/Zilla",
      "lib/Dist/Zilla/Plugin",
      "lib/Dist/Zilla/Plugin/Subversion",
      "t"
   ],
   "dist" : "Dist-Zilla-Plugin-Subversion-NextVersion",
   "dynamic_config" : 0,
   "error" : {},
   "extension" : "tar.gz",
   "external_license_file" : "LICENSE",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_changelog" : "CHANGES",
   "file_dist_ini" : "dist.ini",
   "file_license" : "LICENSE",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_json" : "META.json",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "files_array" : [
      "dist.ini",
      "README",
      "META.json",
      "CHANGES",
      "Makefile.PL",
      "META.yml",
      "MANIFEST",
      "LICENSE",
      "lib/Dist/Zilla/Plugin/Subversion/NextVersion.pm",
      "t/use.t",
      "t/author-critic.t",
      "t/release-pod-syntax.t"
   ],
   "files_hash" : {
      "CHANGES" : {
         "mtime" : 1387802558,
         "size" : 1315
      },
      "LICENSE" : {
         "mtime" : 1387802558,
         "size" : 18404
      },
      "MANIFEST" : {
         "mtime" : 1387802558,
         "size" : 169
      },
      "META.json" : {
         "mtime" : 1387802558,
         "size" : 1755
      },
      "META.yml" : {
         "mtime" : 1387802558,
         "size" : 932
      },
      "Makefile.PL" : {
         "mtime" : 1387802558,
         "size" : 1427,
         "used" : [
            "ExtUtils::MakeMaker",
            "strict",
            "warnings"
         ]
      },
      "README" : {
         "mtime" : 1387802558,
         "size" : 373
      },
      "dist.ini" : {
         "mtime" : 1387802558,
         "size" : 788
      },
      "lib/Dist/Zilla/Plugin/Subversion/NextVersion.pm" : {
         "license" : "Perl_5",
         "module" : "Dist::Zilla::Plugin::Subversion::NextVersion",
         "mtime" : 1387802558,
         "size" : 4322,
         "used" : [
            "Dist::Zilla",
            "Moose",
            "Moose::Util::TypeConstraints",
            "SVN::Client",
            "Try::Tiny",
            "Version::Next",
            "strict",
            "version",
            "warnings"
         ]
      },
      "t/author-critic.t" : {
         "mtime" : 1387802558,
         "required" : [
            "Test::More"
         ],
         "size" : 438,
         "used" : [
            "English",
            "Test::More",
            "strict",
            "warnings"
         ],
         "used_in_eval" : [
            "Test::Perl::Critic"
         ]
      },
      "t/release-pod-syntax.t" : {
         "mtime" : 1387802558,
         "required" : [
            "Test::More"
         ],
         "size" : 296,
         "used" : [
            "Test::More"
         ],
         "used_in_eval" : [
            "Test::Pod"
         ]
      },
      "t/use.t" : {
         "mtime" : 1387802558,
         "size" : 106,
         "used" : [
            "Test::More"
         ]
      }
   },
   "got_prereq_from" : "META.yml",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "easily_repackageable_by_debian" : 1,
      "easily_repackageable_by_fedora" : 1,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "fits_fedora_license" : 1,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 1,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 1,
      "kwalitee" : "95.12",
      "manifest_matches_dist" : 1,
      "metayml_conforms_to_known_spec" : 1,
      "metayml_declares_perl_version" : 0,
      "metayml_has_license" : 1,
      "metayml_has_provides" : 0,
      "metayml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 0,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 1,
      "valid_signature" : 1
   },
   "latest_mtime" : 1387802558,
   "license" : "perl defined in META.yml defined in LICENSE",
   "license_file" : "lib/Dist/Zilla/Plugin/Subversion/NextVersion.pm",
   "license_from_yaml" : "perl",
   "license_in_pod" : 1,
   "license_type" : "Perl_5",
   "licenses" : {
      "Perl_5" : [
         "lib/Dist/Zilla/Plugin/Subversion/NextVersion.pm"
      ]
   },
   "manifest_matches_dist" : 1,
   "meta_yml" : {
      "abstract" : "provide a version number by bumping the last SVN release tag",
      "author" : [
         "Markus Benning <me@w3r3wolf.de>"
      ],
      "build_requires" : {
         "SVN::Client" : "0",
         "Test::More" : "0"
      },
      "configure_requires" : {
         "ExtUtils::MakeMaker" : "6.30"
      },
      "dynamic_config" : "0",
      "generated_by" : "Dist::Zilla version 4.300020, CPAN::Meta::Converter version 2.120921",
      "license" : "perl",
      "meta-spec" : {
         "url" : "http://module-build.sourceforge.net/META-spec-v1.4.html",
         "version" : "1.4"
      },
      "name" : "Dist-Zilla-Plugin-Subversion-NextVersion",
      "requires" : {
         "Dist::Zilla" : "4",
         "Dist::Zilla::Role::BeforeRelease" : "0",
         "Dist::Zilla::Role::VersionProvider" : "0",
         "Moose" : "0",
         "Moose::Util::TypeConstraints" : "0",
         "SVN::Client" : "0",
         "Try::Tiny" : "0",
         "Version::Next" : "0",
         "constant" : "0",
         "strict" : "0",
         "version" : "0",
         "warnings" : "0"
      },
      "resources" : {
         "bugtracker" : "http://rt.cpan.org/NoAuth/Bugs.html?Dist=Dist-Zilla-Plugin-Subversion-NextVersion",
         "repository" : "https://github.com/benningm/Dist-Zilla-Plugin-Subversion-NextVersion"
      },
      "version" : "1.003"
   },
   "metayml_is_parsable" : 1,
   "modules" : [
      {
         "file" : "lib/Dist/Zilla/Plugin/Subversion/NextVersion.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "Dist::Zilla::Plugin::Subversion::NextVersion"
      }
   ],
   "no_pax_headers" : 1,
   "package" : "Dist-Zilla-Plugin-Subversion-NextVersion-1.003.tar.gz",
   "prereq" : [
      {
         "is_prereq" : 1,
         "requires" : "Dist::Zilla::Role::BeforeRelease",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Dist::Zilla::Role::VersionProvider",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "warnings",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "version",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Try::Tiny",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Test::More",
         "type" : "build_requires",
         "version" : "0"
      },
      {
         "requires" : "ExtUtils::MakeMaker",
         "type" : "configure_requires",
         "version" : "6.30"
      },
      {
         "is_prereq" : 1,
         "requires" : "constant",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Moose::Util::TypeConstraints",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Dist::Zilla",
         "type" : "runtime_requires",
         "version" : "4"
      },
      {
         "is_prereq" : 1,
         "requires" : "Moose",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Version::Next",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "strict",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "SVN::Client",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "SVN::Client",
         "type" : "build_requires",
         "version" : "0"
      }
   ],
   "released_epoch" : 1387802568,
   "size_packed" : 10973,
   "size_unpacked" : 30325,
   "uses" : {
      "required_in_tests" : {
         "Test::More" : 2
      },
      "used_in_code" : {
         "Dist::Zilla" : 1,
         "Moose" : 1,
         "Moose::Util::TypeConstraints" : 1,
         "SVN::Client" : 1,
         "Try::Tiny" : 1,
         "Version::Next" : 1,
         "strict" : 1,
         "version" : 1,
         "warnings" : 1
      },
      "used_in_config" : {
         "ExtUtils::MakeMaker" : 1,
         "strict" : 1,
         "warnings" : 1
      },
      "used_in_eval_in_tests" : {
         "Test::Perl::Critic" : 1,
         "Test::Pod" : 1
      },
      "used_in_tests" : {
         "English" : 1,
         "Test::More" : 3,
         "strict" : 1,
         "warnings" : 1
      }
   },
   "valid_signature" : -1,
   "version" : "1.003",
   "versions" : {
      "lib/Dist/Zilla/Plugin/Subversion/NextVersion.pm" : {
         "Dist::Zilla::Plugin::Subversion::NextVersion" : "undef"
      }
   },
   "vname" : "Dist-Zilla-Plugin-Subversion-NextVersion-1.003"
}