Kwalitee Issues


Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: Gearman-Spawner-1.11/lib/Gearman/Spawner/Client/ -- Around line 42: =over without closing =back Gearman-Spawner-1.11/lib/Gearman/Spawner/Client/ -- Around line 39: =over without closing =back


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.


Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.


This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.


Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.


Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).


Name Abstract Version View
Gearman::Spawner Lifecycle manager for Gearman workers 1.11 metacpan
Gearman::Spawner::Client::AnyEvent asynchronous AnyEvent client for Gearman::Spawner::Worker workers metacpan
Gearman::Spawner::Client::Async asynchronous Danga::Socket client for Gearman::Spawner::Worker workers metacpan
Gearman::Spawner::Client::Sync synchronous client for Gearman::Spawner::Worker workers metacpan
Gearman::Spawner::Process metacpan
Gearman::Spawner::Server metacpan
Gearman::Spawner::Supervisor metacpan
Gearman::Spawner::Util metacpan
Gearman::Spawner::Worker metacpan


Name File View
Gearman::Spawner::Server::Instance lib/Gearman/Spawner/ metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan