Kwalitee Issues

extracts_nicely

Pack the distribution with a proper command such as "make dist" and "./Build dist", or use a distribution builder such as Dist::Zilla, Dist::Milla, Minilla.

has_proper_version

Remove all letters from the version number. If you want to mark a release as a developer release, use the scheme 'Module-1.00_01'

package_version_matches_dist_version

Fix the version(s).

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Geo::Coder::Mapquest
  • Geo::Coder::OSM
  • Geo::Coder::OpenCage
  • Geo::Coder::Ovi

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.01,0.02,0.03,0.46

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • English
  • File::Spec
  • strict
  • warnings

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

Modules

Name Abstract Version View
Geo::Coder::Many Module to tie together multiple Geo::Coder::* modules 0.46 metacpan
Geo::Coder::Many::Bing Plugin for the Bing geocoder 0.02 metacpan
Geo::Coder::Many::Generic Base plugin class 0.01 metacpan
Geo::Coder::Many::Google Plugin for the google maps geocoder 0.02 metacpan
Geo::Coder::Many::Googlev3 Plugin for version 3 of the google maps geocoder 0.02 metacpan
Geo::Coder::Many::Mapquest Mapquest plugin Geo::Coder::Many 0.02 metacpan
Geo::Coder::Many::OSM OpenStreetMap Nominatim plugin for Geo::Coder::Many 0.02 metacpan
Geo::Coder::Many::OpenCage OpenCage plugin for Geo::Coder::Many 0.01 metacpan
Geo::Coder::Many::Ovi Ovi plugin Geo::Coder::Many 0.02 metacpan
Geo::Coder::Many::PlaceFinder Yahoo PlaceFinder plugin for Geo::Coder::Many 0.03 metacpan
Geo::Coder::Many::Response standard geocoder response container object 0.01 metacpan
Geo::Coder::Many::Scheduler 0.01 metacpan
Geo::Coder::Many::Scheduler::OrderedList Ordered list scheduler 0.01 metacpan
Geo::Coder::Many::Scheduler::Selective Scheduler that times out bad geocoders 0.01 metacpan
Geo::Coder::Many::Scheduler::UniquenessScheduler Scheduler base class which ensures uniqueness 0.01 metacpan
Geo::Coder::Many::Scheduler::UniquenessScheduler::WRR Weighted Round Robin scheduler (default) 0.01 metacpan
Geo::Coder::Many::Scheduler::UniquenessScheduler::WeightedRandom 0.01 metacpan
Geo::Coder::Many::Util 0.01 metacpan

Other Files

Build.PL metacpan
Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan