Kwalitee Issues


Add a Makefile.PL (for ExtUtils::MakeMaker/Module::Install) or a Build.PL (for Module::Build and its friends), or use a distribution builder such as Dist::Zilla, Dist::Milla, Minilla.


Add a Changelog (best named 'Changes') to the distribution. It should list at least major changes implemented in newer versions.


Add a MANIFEST to the distribution. Your buildtool should be able to autogenerate it (eg "make manifest" or "./Build manifest")


Add a META.yml to the distribution. Your buildtool should be able to autogenerate it.


Remove all letters from the version number. If you want to mark a release as a developer release, use the scheme 'Module-1.00_01'


Add a README to the distribution. It should contain a quick description of your module and how to install it.


Add tests!


Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.

Error: Cannot find MANIFEST in dist.


Fix the version(s).


Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.01,0.02


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


Add tests or move to the t/ directory!


Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.


Move your *.pm files in a directory named 'lib'. The directory structure should look like 'lib/Your/' for a module named 'Your::Module'. If you need to provide additional files, e.g. for testing, that should not be considered for Kwalitee, then you should look at the 'provides' map in META.yml to limit the files scanned; or use the 'no_index' map to exclude parts of the distribution.



Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Geo::GoogleEarth::Document::ColorStyle, Geo::GoogleEarth::Document::Feature, Geo::GoogleEarth::Document::LineString, Geo::GoogleEarth::Document::LineStyle, Geo::GoogleEarth::Document::LinearRing, Geo::GoogleEarth::Document::LookAt, Geo::GoogleEarth::Document::PolyStyle, Geo::GoogleEarth::Document::Polygon, Geo::GoogleEarth::Document::TimeSpan


This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.


Name Abstract Version View
Geo::GoogleEarth::Document::ColorStyle Geo::GoogleEarth::Document::ColorStyle 0.01 metacpan
Geo::GoogleEarth::Document::Feature Geo::GoogleEarth::Document::Feature 0.01 metacpan
Geo::GoogleEarth::Document::LineString Geo::GoogleEarth::Document::LineString 0.02 metacpan
Geo::GoogleEarth::Document::LineStyle Geo::GoogleEarth::Document::LineStyle 0.02 metacpan
Geo::GoogleEarth::Document::LinearRing Geo::GoogleEarth::Document::LinearRing 0.01 metacpan
Geo::GoogleEarth::Document::LookAt Geo::GoogleEarth::Document::LookAt 0.01 metacpan
Geo::GoogleEarth::Document::PolyStyle Geo::GoogleEarth::Document::PolyStyle 0.02 metacpan
Geo::GoogleEarth::Document::Polygon Geo::GoogleEarth::Document::Polygon 0.01 metacpan
Geo::GoogleEarth::Document::TimeSpan Geo::GoogleEarth::Document::TimeSpan 0.01 metacpan