Kwalitee Issues

has_meta_yml

Add a META.yml to the distribution. Your buildtool should be able to autogenerate it.

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: Graph-Template-0.05/lib/Graph/Template/Container/Data.pm -- Around line 146: =back doesn't take any parameters, but you said =back 4 Graph-Template-0.05/lib/Graph/Template/Container/Graph.pm -- Around line 111: =back doesn't take any parameters, but you said =back 4Around line 123: =back doesn't take any parameters, but you said =back 4 Graph-Template-0.05/lib/Graph/Template/Element/DataPoint.pm -- Around line 49: =back doesn't take any parameters, but you said =back 4 Graph-Template-0.05/lib/Graph/Template/Element/Title.pm -- Around line 59: =back doesn't take any parameters, but you said =back 4 Graph-Template-0.05/lib/Graph/Template/Element/Var.pm -- Around line 41: =back doesn't take any parameters, but you said =back 4 Graph-Template-0.05/lib/Graph/Template/Element/XLabel.pm -- Around line 59: =back doesn't take any parameters, but you said =back 4 Graph-Template-0.05/lib/Graph/Template/Element/YLabel.pm -- Around line 59: =back doesn't take any parameters, but you said =back 4 Graph-Template-0.05/lib/Graph/Template.pm -- Around line 313: =back doesn't take any parameters, but you said =back 4

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Exporter

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: Graph::Template::Element::DataPoint

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.01,0.05

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Graph::Template, Graph::Template::Base, Graph::Template::Constants, Graph::Template::Container, Graph::Template::Container::Data, Graph::Template::Container::Graph, Graph::Template::Container::Scope, Graph::Template::Context, Graph::Template::Element, Graph::Template::Element::DataPoint, Graph::Template::Element::Title, Graph::Template::Element::Var, Graph::Template::Element::XLabel, Graph::Template::Element::YLabel, Graph::Template::Factory, Graph::Template::Iterator, Graph::Template::TextObject

Modules

Name Abstract Version View
Graph::Template Graph::Template 0.05 metacpan
Graph::Template::Base 0.01 metacpan
Graph::Template::Constants 0.01 metacpan
Graph::Template::Container metacpan
Graph::Template::Container::Data metacpan
Graph::Template::Container::Graph Graph::Template::Container::Graph metacpan
Graph::Template::Container::Scope metacpan
Graph::Template::Context metacpan
Graph::Template::Element metacpan
Graph::Template::Element::DataPoint metacpan
Graph::Template::Element::Title metacpan
Graph::Template::Element::Var metacpan
Graph::Template::Element::XLabel metacpan
Graph::Template::Element::YLabel metacpan
Graph::Template::Factory metacpan
Graph::Template::Iterator metacpan
Graph::Template::TextObject metacpan

Other Files

Changes metacpan
MANIFEST metacpan
Makefile.PL metacpan
README metacpan