Kwalitee Issues

No Core Issues.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: LWPx::ParanoidAgent, LWPx::Protocol::http_paranoid, LWPx::Protocol::https_paranoid

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

Modules

Name Abstract Version View
LWPx::ParanoidAgent subclass of LWP::UserAgent that protects you from harm 1.10 metacpan
LWPx::Protocol::http_paranoid metacpan
LWPx::Protocol::https_paranoid metacpan

Provides

Name File View
LWPx::Protocol::http_paranoid::Socket lib/LWPx/Protocol/http_paranoid.pm metacpan
LWPx::Protocol::http_paranoid::SocketMethods lib/LWPx/Protocol/http_paranoid.pm metacpan
LWPx::Protocol::https_paranoid::Socket lib/LWPx/Protocol/https_paranoid.pm metacpan

Other Files

ChangeLog metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan
README.md metacpan