Under maintenance.

Most probably CPANTS databases are being regenerated from scratch due to major changes in Kwalitee metrics or updates of relevant modules/perl. Usually this maintenance takes about a day or two, and some of the information may be old or missing tentatively. Sorry for the inconvenience.

Kwalitee Issues

has_abstract_in_pod

Provide a short description in the NAME section of the pod (after the module name followed by a hyphen) at least for the main module of this distribution.

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: Lemonldap::NG::Common::Apache::Session::Store, Lemonldap::NG::Common::CGI::SOAPServer, Lemonldap::NG::Common::CGI::SOAPService, Lemonldap::NG::Common::Conf::DefaultValues, Lemonldap::NG::Common::Conf::JSONFile, Lemonldap::NG::Common::Regexp

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 1.004004,1.009001,1.009003,1.009004,1.009005

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Lemonldap::NG::Common, Lemonldap::NG::Common::Apache::Session, Lemonldap::NG::Common::Apache::Session::Generate::SHA256, Lemonldap::NG::Common::Apache::Session::Lock, Lemonldap::NG::Common::Apache::Session::SOAP, Lemonldap::NG::Common::Apache::Session::Serialize::JSON, Lemonldap::NG::Common::Apache::Session::Store, Lemonldap::NG::Common::CGI, Lemonldap::NG::Common::CGI::SOAPServer, Lemonldap::NG::Common::CGI::SOAPService, Lemonldap::NG::Common::Conf, Lemonldap::NG::Common::Conf::CDBI, Lemonldap::NG::Common::Conf::Constants, Lemonldap::NG::Common::Conf::DBI, Lemonldap::NG::Common::Conf::DefaultValues, Lemonldap::NG::Common::Conf::File, Lemonldap::NG::Common::Conf::JSONFile, Lemonldap::NG::Common::Conf::LDAP, Lemonldap::NG::Common::Conf::MongoDB, Lemonldap::NG::Common::Conf::RDBI, Lemonldap::NG::Common::Conf::SOAP, Lemonldap::NG::Common::Conf::Serializer, Lemonldap::NG::Common::Conf::_DBI, Lemonldap::NG::Common::Crypto, Lemonldap::NG::Common::Notification, Lemonldap::NG::Common::Notification::DBI, Lemonldap::NG::Common::Notification::File, Lemonldap::NG::Common::Notification::LDAP, Lemonldap::NG::Common::PSGI::Constants, Lemonldap::NG::Common::Regexp, Lemonldap::NG::Common::Safe, Lemonldap::NG::Common::Safelib

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Lemonldap::NG::Common 1.009005 metacpan
Lemonldap::NG::Common::Apache::Session 1.009005 metacpan
Lemonldap::NG::Common::Apache::Session::Generate::SHA256 1.009001 metacpan
Lemonldap::NG::Common::Apache::Session::Lock 1.004004 metacpan
Lemonldap::NG::Common::Apache::Session::SOAP 1.009001 metacpan
Lemonldap::NG::Common::Apache::Session::Serialize::JSON 1.009005 metacpan
Lemonldap::NG::Common::Apache::Session::Store 1.009001 metacpan
Lemonldap::NG::Common::CGI 1.009001 metacpan
Lemonldap::NG::Common::CGI::SOAPServer 1.009001 metacpan
Lemonldap::NG::Common::CGI::SOAPService 1.009001 metacpan
Lemonldap::NG::Common::Captcha 1.009001 metacpan
Lemonldap::NG::Common::Cli metacpan
Lemonldap::NG::Common::Conf 1.009001 metacpan
Lemonldap::NG::Common::Conf::CDBI 1.009001 metacpan
Lemonldap::NG::Common::Conf::Constants 1.009005 metacpan
Lemonldap::NG::Common::Conf::DBI 1.009001 metacpan
Lemonldap::NG::Common::Conf::DefaultValues 1.009005 metacpan
Lemonldap::NG::Common::Conf::File 1.009001 metacpan
Lemonldap::NG::Common::Conf::JSONFile metacpan
Lemonldap::NG::Common::Conf::LDAP 1.009005 metacpan
Lemonldap::NG::Common::Conf::MongoDB 1.009001 metacpan
Lemonldap::NG::Common::Conf::RDBI 1.009001 metacpan
Lemonldap::NG::Common::Conf::SAML::Metadata 1.009001 metacpan
Lemonldap::NG::Common::Conf::SOAP 1.009001 metacpan
Lemonldap::NG::Common::Conf::Serializer 1.009001 metacpan
Lemonldap::NG::Common::Conf::_DBI 1.009001 metacpan
Lemonldap::NG::Common::Crypto 1.009001 metacpan
Lemonldap::NG::Common::Notification 1.009001 metacpan
Lemonldap::NG::Common::Notification::DBI 1.009001 metacpan
Lemonldap::NG::Common::Notification::File 1.009001 metacpan
Lemonldap::NG::Common::Notification::LDAP 1.009001 metacpan
Lemonldap::NG::Common::PSGI 1.009003 metacpan
Lemonldap::NG::Common::PSGI::Cli::Lib metacpan
Lemonldap::NG::Common::PSGI::Constants 1.009001 metacpan
Lemonldap::NG::Common::PSGI::Request 1.009004 metacpan
Lemonldap::NG::Common::PSGI::Router 1.009001 metacpan
Lemonldap::NG::Common::Regexp metacpan
Lemonldap::NG::Common::Safe 1.009001 metacpan
Lemonldap::NG::Common::Safelib 1.009001 metacpan
Lemonldap::NG::Common::Session 1.009001 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan