Kwalitee Issues


Add a META.yml to the distribution. Your buildtool should be able to autogenerate it.


List all used modules in META.yml requires


  • Math::LP::Solve
  • Math::LinearCombination
  • Math::SimpleVariable


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.


Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Math::LP, Math::LP::Constraint, Math::LP::LinearCombination, Math::LP::Object, Math::LP::Variable


This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.


Name Abstract Version View
Math::LP OO interface to linear programs 0.03 metacpan
Math::LP::Constraint representation of constraints in Math::LP objects metacpan
Math::LP::LinearCombination linear combination of Math::LP::Variable objects metacpan
Math::LP::Object base class for objects in the Math::LP family metacpan
Math::LP::Variable variables used in linear programs metacpan

Other Files

Changes metacpan
MANIFEST metacpan
Makefile.PL metacpan
README metacpan