Kwalitee Issues

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Carp
  • Exporter
  • Tie::Array
  • constant
  • strict
  • warnings

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • Carp
  • Config
  • List::Util
  • Math::BigFloat
  • Math::BigInt
  • Test::More
  • bigint
  • bignum
  • strict
  • warnings

Modules

Name Abstract Version View
Math::Prime::Util Utilities related to prime numbers, including fast sieves and factoring 0.58 metacpan
Math::Prime::Util::MemFree An auto-free object for Math::Prime::Util 0.58 metacpan
Math::Prime::Util::PP Pure Perl version of Math::Prime::Util 0.58 metacpan
Math::Prime::Util::PrimeArray A tied array for primes 0.58 metacpan
Math::Prime::Util::PrimeIterator An object iterator for primes 0.58 metacpan
ntheory Number theory utilities 0.58 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan
cpanfile metacpan