Kwalitee Issues

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: Memcached::libmemcached::API, Memcached::libmemcached::constants, Memcached::libmemcached::memcached_analyze, Memcached::libmemcached::memcached_auto, Memcached::libmemcached::memcached_behavior, Memcached::libmemcached::memcached_callback, Memcached::libmemcached::memcached_create, Memcached::libmemcached::memcached_delete, Memcached::libmemcached::memcached_dump, Memcached::libmemcached::memcached_flush, Memcached::libmemcached::memcached_flush_buffers, Memcached::libmemcached::memcached_generate_hash_value, Memcached::libmemcached::memcached_get, Memcached::libmemcached::memcached_memory_allocators, Memcached::libmemcached::memcached_pool, Memcached::libmemcached::memcached_quit, Memcached::libmemcached::memcached_result_st, Memcached::libmemcached::memcached_sasl, Memcached::libmemcached::memcached_server_st, Memcached::libmemcached::memcached_servers, Memcached::libmemcached::memcached_set, Memcached::libmemcached::memcached_stats, Memcached::libmemcached::memcached_strerror, Memcached::libmemcached::memcached_user_data, Memcached::libmemcached::memcached_verbosity, Memcached::libmemcached::memcached_version

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Memcached::libmemcached::API, Memcached::libmemcached::constants, Memcached::libmemcached::memcached_analyze, Memcached::libmemcached::memcached_auto, Memcached::libmemcached::memcached_behavior, Memcached::libmemcached::memcached_callback, Memcached::libmemcached::memcached_create, Memcached::libmemcached::memcached_delete, Memcached::libmemcached::memcached_dump, Memcached::libmemcached::memcached_flush, Memcached::libmemcached::memcached_flush_buffers, Memcached::libmemcached::memcached_generate_hash_value, Memcached::libmemcached::memcached_get, Memcached::libmemcached::memcached_memory_allocators, Memcached::libmemcached::memcached_pool, Memcached::libmemcached::memcached_quit, Memcached::libmemcached::memcached_result_st, Memcached::libmemcached::memcached_sasl, Memcached::libmemcached::memcached_server_st, Memcached::libmemcached::memcached_servers, Memcached::libmemcached::memcached_set, Memcached::libmemcached::memcached_stats, Memcached::libmemcached::memcached_strerror, Memcached::libmemcached::memcached_user_data, Memcached::libmemcached::memcached_verbosity, Memcached::libmemcached::memcached_version

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

Modules

Name Abstract Version View
Memcached::libmemcached Thin fast full interface to the libmemcached client API 1.001801 metacpan
Memcached::libmemcached::API Private volitile module metacpan
Memcached::libmemcached::memcached_analyze metacpan
Memcached::libmemcached::memcached_auto metacpan
Memcached::libmemcached::memcached_behavior metacpan
Memcached::libmemcached::memcached_callback metacpan
Memcached::libmemcached::memcached_create metacpan
Memcached::libmemcached::memcached_delete metacpan
Memcached::libmemcached::memcached_dump metacpan
Memcached::libmemcached::memcached_flush metacpan
Memcached::libmemcached::memcached_flush_buffers metacpan
Memcached::libmemcached::memcached_generate_hash_value metacpan
Memcached::libmemcached::memcached_get metacpan
Memcached::libmemcached::memcached_memory_allocators metacpan
Memcached::libmemcached::memcached_pool metacpan
Memcached::libmemcached::memcached_quit metacpan
Memcached::libmemcached::memcached_result_st metacpan
Memcached::libmemcached::memcached_sasl metacpan
Memcached::libmemcached::memcached_server_st metacpan
Memcached::libmemcached::memcached_servers metacpan
Memcached::libmemcached::memcached_set metacpan
Memcached::libmemcached::memcached_stats metacpan
Memcached::libmemcached::memcached_strerror metacpan
Memcached::libmemcached::memcached_user_data metacpan
Memcached::libmemcached::memcached_verbosity metacpan
Memcached::libmemcached::memcached_version metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README.md metacpan