Kwalitee Issues

no_pax_headers

If you use Mac OS X >= 10.6, use gnu tar (/usr/bin/gnutar) to avoid PAX headers. It's also important to rename (shorten) long file names (>= 100 characters) in the distribution.

Error: ./PaxHeaders.2618/Mojolicious-Plugin-OnFork-0.003,./PaxHeaders.2618/Mojolicious-Plugin-OnFork-0.003,Mojolicious-Plugin-OnFork-0.003/PaxHeaders.2618/lib,Mojolicious-Plugin-OnFork-0.003/PaxHeaders.2618/lib,Mojolicious-Plugin-OnFork-0.003/lib/PaxHeaders.2618/Mojolicious,Mojolicious-Plugin-OnFork-0.003/lib/PaxHeaders.2618/Mojolicious,Mojolicious-Plugin-OnFork-0.003/lib/Mojolicious/PaxHeaders.2618/Plugin,Mojolicious-Plugin-OnFork-0.003/lib/Mojolicious/PaxHeaders.2618/Plugin,Mojolicious-Plugin-OnFork-0.003/lib/Mojolicious/Plugin/PaxHeaders.2618/OnFork.pm,Mojolicious-Plugin-OnFork-0.003/lib/Mojolicious/Plugin/PaxHeaders.2618/OnFork.pm,Mojolicious-Plugin-OnFork-0.003/PaxHeaders.2618/META.yml,Mojolicious-Plugin-OnFork-0.003/PaxHeaders.2618/META.yml,Mojolicious-Plugin-OnFork-0.003/PaxHeaders.2618/README,Mojolicious-Plugin-OnFork-0.003/PaxHeaders.2618/README,Mojolicious-Plugin-OnFork-0.003/PaxHeaders.2618/t,Mojolicious-Plugin-OnFork-0.003/PaxHeaders.2618/t,Mojolicious-Plugin-OnFork-0.003/t/PaxHeaders.2618/01-hypnotoad.t,Mojolicious-Plugin-OnFork-0.003/t/PaxHeaders.2618/01-hypnotoad.t,Mojolicious-Plugin-OnFork-0.003/PaxHeaders.2618/MANIFEST.skip,Mojolicious-Plugin-OnFork-0.003/PaxHeaders.2618/MANIFEST.skip,Mojolicious-Plugin-OnFork-0.003/PaxHeaders.2618/inc,Mojolicious-Plugin-OnFork-0.003/PaxHeaders.2618/inc,Mojolicious-Plugin-OnFork-0.003/inc/PaxHeaders.2618/Module,Mojolicious-Plugin-OnFork-0.003/inc/PaxHeaders.2618/Module,Mojolicious-Plugin-OnFork-0.003/inc/Module/PaxHeaders.2618/AutoInstall.pm,Mojolicious-Plugin-OnFork-0.003/inc/Module/PaxHeaders.2618/AutoInstall.pm,Mojolicious-Plugin-OnFork-0.003/inc/Module/PaxHeaders.2618/Install,Mojolicious-Plugin-OnFork-0.003/inc/Module/PaxHeaders.2618/Install,Mojolicious-Plugin-OnFork-0.003/inc/Module/Install/PaxHeaders.2618/Include.pm,Mojolicious-Plugin-OnFork-0.003/inc/Module/Install/PaxHeaders.2618/Include.pm,Mojolicious-Plugin-OnFork-0.003/inc/Module/Install/PaxHeaders.2618/Makefile.pm,Mojolicious-Plugin-OnFork-0.003/inc/Module/Install/PaxHeaders.2618/Makefile.pm,Mojolicious-Plugin-OnFork-0.003/inc/Module/Install/PaxHeaders.2618/Win32.pm,Mojolicious-Plugin-OnFork-0.003/inc/Module/Install/PaxHeaders.2618/Win32.pm,Mojolicious-Plugin-OnFork-0.003/inc/Module/Install/PaxHeaders.2618/Metadata.pm,Mojolicious-Plugin-OnFork-0.003/inc/Module/Install/PaxHeaders.2618/Metadata.pm,Mojolicious-Plugin-OnFork-0.003/inc/Module/Install/PaxHeaders.2618/Fetch.pm,Mojolicious-Plugin-OnFork-0.003/inc/Module/Install/PaxHeaders.2618/Fetch.pm,Mojolicious-Plugin-OnFork-0.003/inc/Module/Install/PaxHeaders.2618/Can.pm,Mojolicious-Plugin-OnFork-0.003/inc/Module/Install/PaxHeaders.2618/Can.pm,Mojolicious-Plugin-OnFork-0.003/inc/Module/Install/PaxHeaders.2618/AutoInstall.pm,Mojolicious-Plugin-OnFork-0.003/inc/Module/Install/PaxHeaders.2618/AutoInstall.pm,Mojolicious-Plugin-OnFork-0.003/inc/Module/Install/PaxHeaders.2618/WriteAll.pm,Mojolicious-Plugin-OnFork-0.003/inc/Module/Install/PaxHeaders.2618/WriteAll.pm,Mojolicious-Plugin-OnFork-0.003/inc/Module/Install/PaxHeaders.2618/Base.pm,Mojolicious-Plugin-OnFork-0.003/inc/Module/Install/PaxHeaders.2618/Base.pm,Mojolicious-Plugin-OnFork-0.003/inc/Module/PaxHeaders.2618/Install.pm,Mojolicious-Plugin-OnFork-0.003/inc/Module/PaxHeaders.2618/Install.pm,Mojolicious-Plugin-OnFork-0.003/PaxHeaders.2618/Makefile.PL,Mojolicious-Plugin-OnFork-0.003/PaxHeaders.2618/Makefile.PL,Mojolicious-Plugin-OnFork-0.003/PaxHeaders.2618/Changes,Mojolicious-Plugin-OnFork-0.003/PaxHeaders.2618/Changes,Mojolicious-Plugin-OnFork-0.003/PaxHeaders.2618/MANIFEST,Mojolicious-Plugin-OnFork-0.003/PaxHeaders.2618/MANIFEST

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • File::Spec::Functions
  • File::Temp
  • FindBin
  • IO::Socket::INET

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

Modules

Name Abstract Version View
Mojolicious::Plugin::OnFork Do Something Whenever a Worker Starts 0.003 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan