Kwalitee Issues


Take a look at the META.yml Spec at (for version 1.4) or (for version 2), and change your META.yml accordingly.

Error: '' for 'perl' is not a valid version. (requires -> perl) [Validation: 1.4];Missing mandatory field, 'abstract' (abstract) [Validation: 1.4];value is an undefined string (abstract) [Validation: 1.4]


Fix the version(s).


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.


Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.


Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).


Name Abstract Version View
Object::By::Array minimalistic constructors for array based objects metacpan
Object::By::Array_Accessor metacpan
Object::By::Array_Clone_Recursive metacpan
Object::By::Existing_Reference a minimalistic constructor for objects based on existing references metacpan
Object::By::Hash minimalistic constructors for hash based objects metacpan
Object::By::Hash_Accessor metacpan
Object::By::Hash_Clone_Recursive metacpan
Object::By::Scalar minimalistic constructors for scalar based objects metacpan
Object::By::Scalar_Accessor metacpan
Object::By::Typeglob minimalistic constructors for typeglob based objects metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan