Kwalitee Issues

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Carp
  • overload
  • strict
  • warnings

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • strict
  • warnings

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

Modules

Name Abstract Version View
Object::eBay Object-oriented interface to the eBay API v0.5.1 metacpan
Object::eBay::Attribute Represents an item attribute v0.5.1 metacpan
Object::eBay::Attributes Represents item attributes v0.5.1 metacpan
Object::eBay::Boolean Represents a boolean return value v0.5.1 metacpan
Object::eBay::Condition Represents a condition used by eBay v0.5.1 metacpan
Object::eBay::Currency Represents a currency used by eBay v0.5.1 metacpan
Object::eBay::Item Represents an item listed on eBay v0.5.1 metacpan
Object::eBay::ListingDetails Represents an item's listing details v0.5.1 metacpan
Object::eBay::SellingStatus Represents an item's selling status v0.5.1 metacpan
Object::eBay::User Represents an eBay user v0.5.1 metacpan

Other Files

Build.PL metacpan
Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan