Kwalitee Issues

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: PIX-Walker-1.10/lib/PIX/Accesslist/Line.pm -- Around line 323: You forgot a '=back' before '=head1' PIX-Walker-1.10/lib/PIX/Accesslist.pm -- Around line 282: You forgot a '=back' before '=head1' PIX-Walker-1.10/lib/PIX/Object/icmp_type.pm -- Around line 224: You forgot a '=back' before '=head1' PIX-Walker-1.10/lib/PIX/Object/network.pm -- Around line 274: You forgot a '=back' before '=head1' PIX-Walker-1.10/lib/PIX/Object/protocol.pm -- Around line 106: You forgot a '=back' before '=head1' PIX-Walker-1.10/lib/PIX/Object/service.pm -- Around line 194: You forgot a '=back' before '=head1' PIX-Walker-1.10/lib/PIX/Object.pm -- Around line 153: You forgot a '=back' before '=head1' PIX-Walker-1.10/lib/PIX/Walker.pm -- Around line 546: You forgot a '=back' before '=head1' You forgot a '=back' before '=head1'

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Carp
  • Exporter
  • strict
  • warnings

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • strict
  • warnings

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
PIX::Accesslist Accesslist object for use with PIX::Walker 1.10 metacpan
PIX::Accesslist::Line ACL line object for each line of an PIX::Accesslist. 1.10 metacpan
PIX::Object Factory class for the various object-groups found in a PIX config from a PIX::Walker object. This object is not meant to be instantiated directly. 1.10 metacpan
PIX::Object::icmp_type Class for "icmp-type" object-groups found in a PIX config. 1.10 metacpan
PIX::Object::network Class for "network" object-groups found in a PIX config. 1.10 metacpan
PIX::Object::protocol Class for "protocol" object-groups found in a PIX config. A protocol group is used on access-lists to allow a line of an ACL to have multiple protocols on it (ip, tcp, udp, gmp, ah, es, etc...). 1.10 metacpan
PIX::Object::service Class for "service" object-groups found in a PIX config. 1.10 metacpan
PIX::Walker Process Cisco PIX configs and 'walk' access-lists 1.10 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan