Kwalitee Issues


Change the permissions of Build.PL/Makefile.PL to not-executable.


Add a Changelog (best named 'Changes') to the distribution. It should list at least major changes implemented in newer versions.


Add a section called "LICENSE" to the documentation, or add a file named LICENSE to the distribution.


Add =head1 LICENSE and the text of the license to the main module in your code.


Add tests!


Take a look at the META.yml Spec at (for version 1.4) or (for version 2), and change your META.yml accordingly.

Error: Expected a map structure from string or file. (requires) [Validation: 1.0]


Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.01,0.02


Add =head1 LICENSE and/or the proper text of the well-known license to the main module in your code.


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


Add tests or move to the t/ directory!


If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.


Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.


Move your *.pm files in a directory named 'lib'. The directory structure should look like 'lib/Your/' for a module named 'Your::Module'. If you need to provide additional files, e.g. for testing, that should not be considered for Kwalitee, then you should look at the 'provides' map in META.yml to limit the files scanned; or use the 'no_index' map to exclude parts of the distribution.

Error: tests/


Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Parse::Pidl, Parse::Pidl::Compat, Parse::Pidl::Dump, Parse::Pidl::Ethereal::Conformance, Parse::Pidl::Ethereal::NDR, Parse::Pidl::NDR, Parse::Pidl::ODL, Parse::Pidl::Samba4::COM::Header, Parse::Pidl::Samba4::COM::Proxy, Parse::Pidl::Samba4::COM::Stub, Parse::Pidl::Samba4::EJS, Parse::Pidl::Samba4::Header, Parse::Pidl::Samba4::NDR::Client, Parse::Pidl::Samba4::NDR::Parser, Parse::Pidl::Samba4::NDR::Server, Parse::Pidl::Samba4::SWIG, Parse::Pidl::Samba4::TDR, Parse::Pidl::Samba4::Template, Parse::Pidl::Typelist, Parse::Pidl::Util, Util


This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.


Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.


Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).


Name Abstract Version View
Parse::Pidl 0.02 metacpan
Parse::Pidl::Compat 0.01 metacpan
Parse::Pidl::Dump Dump support 0.01 metacpan
Parse::Pidl::Ethereal::Conformance Conformance file parser for Ethereal 0.01 metacpan
Parse::Pidl::Ethereal::NDR Parser generator for Ethereal 0.01 metacpan
Parse::Pidl::NDR NDR parsing information generator 0.01 metacpan
Parse::Pidl::ODL 0.01 metacpan
Parse::Pidl::Samba4::COM::Header 0.01 metacpan
Parse::Pidl::Samba4::COM::Proxy 0.01 metacpan
Parse::Pidl::Samba4::COM::Stub 0.01 metacpan
Parse::Pidl::Samba4::EJS 0.01 metacpan
Parse::Pidl::Samba4::Header 0.01 metacpan
Parse::Pidl::Samba4::NDR::Client 0.01 metacpan
Parse::Pidl::Samba4::NDR::Parser 0.01 metacpan
Parse::Pidl::Samba4::NDR::Server 0.01 metacpan
Parse::Pidl::Samba4::SWIG 0.01 metacpan
Parse::Pidl::Samba4::TDR 0.01 metacpan
Parse::Pidl::Samba4::Template 0.01 metacpan
Parse::Pidl::Typelist 0.01 metacpan
Parse::Pidl::Util 0.01 metacpan
Util metacpan

Other Files

MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan