Kwalitee Issues


Add a Changelog (best named 'Changes') to the distribution. It should list at least major changes implemented in newer versions.


Add a section called "LICENSE" to the documentation, or add a file named LICENSE to the distribution.


Add =head1 LICENSE and the text of the license to the main module in your code.


Add a META.yml to the distribution. Your buildtool should be able to autogenerate it.


Add =head1 LICENSE and/or the proper text of the well-known license to the main module in your code.


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


Add tests or move to the t/ directory!


Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.


Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Parse::YALALR::Build, Parse::YALALR::Common, Parse::YALALR::Generate::C, Parse::YALALR::Kernel, Parse::YALALR::Parser, Parse::YALALR::Read, Parse::YALALR::Run, Parse::YALALR::Vector


This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.


Name Abstract Version View
Parse::YALALR::Build metacpan
Parse::YALALR::Common metacpan
Parse::YALALR::Generate::C metacpan
Parse::YALALR::Kernel metacpan
Parse::YALALR::Parser metacpan
Parse::YALALR::Read metacpan
Parse::YALALR::Run 0.02 metacpan
Parse::YALALR::Vector metacpan


Name File View
Parse::YALALR::Common::Identity lib/Parse/YALALR/ metacpan
Parse::YALALR::Common::Plural lib/Parse/YALALR/ metacpan
Parse::YALALR::Common::XMLEscape lib/Parse/YALALR/ metacpan
Parse::YALALR::Common::XMLUnescape lib/Parse/YALALR/ metacpan
chain lib/Parse/YALALR/ metacpan
item lib/Parse/YALALR/ metacpan

Other Files

MANIFEST metacpan
Makefile.PL metacpan
README metacpan