Kwalitee Issues

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: Perl6-Pod-0.72/lib/Perl6/Pod/Directive/alias.pm -- Around line 27: Deleting unknown formatting code A<> Perl6-Pod-0.72/lib/Perl6/Pod/FormattingCode/L.pm -- Around line 19: An empty L<> Perl6-Pod-0.72/lib/Perl6/Pod/FormattingCode/M.pm -- Around line 19: Deleting unknown formatting code M<> Deleting unknown formatting code M<>Around line 28: Deleting unknown formatting code M<> Perl6-Pod-0.72/lib/Perl6/Pod/FormattingCode/T.pm -- Around line 22: Deleting unknown formatting code T<> Perl6-Pod-0.72/lib/Perl6/Pod/FormattingCode/X.pm -- Around line 79: You forgot a '=back' before '=head2' Perl6-Pod-0.72/lib/Perl6/Pod/Parser/Utils.pm -- Around line 19: =back without =over Perl6-Pod-0.72/lib/Perl6/Pod/Utl/Context.pm -- Around line 37: =pod directives shouldn't be over one line long! Ignoring all 4 lines of contentAround line 164: Non-ASCII character seen before =encoding in 'С<block_name>'. Assuming UTF-8 Perl6-Pod-0.72/lib/Perl6/Pod/Utl.pm -- Around line 16: '=item' outside of any '=over'Around line 46: You forgot a '=back' before '=head2'Around line 84: '=item' outside of any '=over' =over without closing =back Perl6-Pod-0.72/lib/Perl6/Pod.pm -- Around line 194: Deleting unknown formatting code V<>

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: Perl6::Pod::Parser::Utils

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.01,0.72

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Perl6::Pod::FormattingCode::M, Perl6::Pod::FormattingCode::X, Perl6::Pod::Parser::Utils

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

Modules

Name Abstract Version View
Perl6::Pod Pod6 implementation 0.72 metacpan
Perl6::Pod::Block base class for Perldoc blocks 0.01 metacpan
Perl6::Pod::Block::SEMANTIC 0.01 metacpan
Perl6::Pod::Block::code Verbatim pre-formatted sample source code 0.01 metacpan
Perl6::Pod::Block::comment handle =comment block 0.01 metacpan
Perl6::Pod::Block::head handle B<=head> - Headings 0.01 metacpan
Perl6::Pod::Block::input handle =input block 0.01 metacpan
Perl6::Pod::Block::item lists 0.01 metacpan
Perl6::Pod::Block::nested Nesting blocks 0.01 metacpan
Perl6::Pod::Block::output handle =output block 0.01 metacpan
Perl6::Pod::Block::para handle B<=para> -ordinary paragraph 0.01 metacpan
Perl6::Pod::Block::table Simple tables 0.01 metacpan
Perl6::Pod::Codeactions 0.01 metacpan
Perl6::Pod::Directive::alias synonyms for longer Pod sequences 0.01 metacpan
Perl6::Pod::Directive::config handle =config directive 0.01 metacpan
Perl6::Pod::Directive::use handle =use directive 0.01 metacpan
Perl6::Pod::FormattingCode base class for formatting code 0.01 metacpan
Perl6::Pod::FormattingCode::A Replaced by contents of specified macro/object 0.01 metacpan
Perl6::Pod::FormattingCode::B Basis/focus of sentence 0.01 metacpan
Perl6::Pod::FormattingCode::C Contained text is code 0.01 metacpan
Perl6::Pod::FormattingCode::D Definition 0.01 metacpan
Perl6::Pod::FormattingCode::E include named Unicode or XHTML entities 0.01 metacpan
Perl6::Pod::FormattingCode::I Important 0.01 metacpan
Perl6::Pod::FormattingCode::K keyboard input 0.01 metacpan
Perl6::Pod::FormattingCode::L handle "L" formatting code 0.01 metacpan
Perl6::Pod::FormattingCode::M class of M code 0.01 metacpan
Perl6::Pod::FormattingCode::N inline note 0.01 metacpan
Perl6::Pod::FormattingCode::P handle "P" formatting code 0.01 metacpan
Perl6::Pod::FormattingCode::R Replaceable item 0.01 metacpan
Perl6::Pod::FormattingCode::S Space-preserving text 0.01 metacpan
Perl6::Pod::FormattingCode::T Terminal output 0.01 metacpan
Perl6::Pod::FormattingCode::U Unusual text 0.01 metacpan
Perl6::Pod::FormattingCode::X index entry 0.01 metacpan
Perl6::Pod::FormattingCode::Z Inline comments 0.01 metacpan
Perl6::Pod::Grammars set of grammars for Pod6 0.01 metacpan
Perl6::Pod::Lex 0.01 metacpan
Perl6::Pod::Lex::Block 0.01 metacpan
Perl6::Pod::Lex::FormattingCode 0.01 metacpan
Perl6::Pod::Lex::RawText 0.01 metacpan
Perl6::Pod::Lex::Text 0.01 metacpan
Perl6::Pod::Parser::AddIds generate attribute id for elements 0.01 metacpan
Perl6::Pod::Parser::Context 0.01 metacpan
Perl6::Pod::Parser::CustomCodes Filter for handle custom codes 0.01 metacpan
Perl6::Pod::Parser::Utils set of useful functions 0.01 metacpan
Perl6::Pod::Test test lib 0.01 metacpan
Perl6::Pod::To base class for output formatters 0.01 metacpan
Perl6::Pod::To::DocBook DocBook formater 0.01 metacpan
Perl6::Pod::To::Latex 0.01 metacpan
Perl6::Pod::To::Test 0.01 metacpan
Perl6::Pod::To::XHTML XHTML formater 0.01 metacpan
Perl6::Pod::Utl 0.01 metacpan
Perl6::Pod::Utl::AbstractVisiter 0.01 metacpan
Perl6::Pod::Utl::Context 0.01 metacpan
Perl6::Pod::Writer 0.01 metacpan
Perl6::Pod::Writer::Latex 0.01 metacpan

Other Files

Build.PL metacpan
Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan