Poet

Prerequisites

Poet declares the following 29 modules as prerequisites.

Listed PrerequisitesRequired VersionLatest DistKwalitee
CHI0.52CHI-0.58125.71
Capture::Tiny0Capture-Tiny-0.27134.29
Class::Load0Class-Load-0.22134.29
Data::Rmap0.6Data-Rmap-0.64128.57
File::ShareDir0File-ShareDir-1.102128.57
File::ShareDir::Install0File-ShareDir-Install-0.10128.57
File::Slurp0File-Slurp-9999.19120.00
File::Spec::Functions0PathTools-3.47122.86
Guard0Guard-1.023117.14
JSON::XS0JSON-XS-3.01117.14
Log::Any::Adapter0Log-Any-Adapter-0.11128.57
Mason2.19Mason-2.22120.00
Mason::Plugin::Cache0.04Mason-Plugin-Cache-0.05122.86
Mason::Plugin::HTMLFilters0Mason-Plugin-HTMLFilters-0.03117.14
Mason::Plugin::RouterSimple0.05Mason-Plugin-RouterSimple-0.07117.14
MasonX::ProcessDir0.02MasonX-ProcessDir-0.02122.86
Method::Signatures::Simple1.02Method-Signatures-Simple-1.07131.43
Moose1.15Moose-2.1403134.29
MooseX::App::Cmd0MooseX-App-Cmd-0.27131.43
MooseX::HasDefaults::RO0MooseX-HasDefaults-0.03120.00
MooseX::StrictConstructor0MooseX-StrictConstructor-0.19131.43
Plack0Plack-1.0033128.57
Plack::Middleware::Debug0Plack-Middleware-Debug-0.16128.57
Plack::Middleware::Session0Plack-Middleware-Session-0.25125.71
Plack::Session::Store::Cache0Plack-Middleware-Session-0.25125.71
Try::Tiny0Try-Tiny-0.22134.29
URI0URI-1.65131.43
URI::Escape0URI-1.65131.43
YAML::XS0YAML-LibYAML-0.54128.57

Poet declares the following 2 modules as build prerequisites.

Listed Build PrerequisitesRequired VersionLatest DistKwalitee
Test::Class::Most0Test-Class-Most-0.08131.43
Test::WWW::Mechanize::PSGI0Test-WWW-Mechanize-PSGI-0.35131.43

Poet declares the following 4 modules as optional prerequisites.

Listed Optional PrerequisitesRequired VersionLatest DistKwalitee
ExtUtils::MakeMaker6.30ExtUtils-MakeMaker-7.04131.428571428571
File::ShareDir::Install0.03File-ShareDir-Install-0.10128.571428571429
Log::Any::Adapter::Log4perl0Log-Any-Adapter-Log4perl-0.06128.571428571429
Log::Log4perl0Log-Log4perl-1.46117.142857142857