Kwalitee Issues

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Data::MessagePack
  • JSON::XS

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • strict
  • warnings

Modules

Name Abstract Version View
Qudo simple and extensible job queue manager 0.0214 metacpan
Qudo::Driver::Skinny metacpan
Qudo::Driver::Skinny::Row::ExceptionLog metacpan
Qudo::Driver::Skinny::Row::Func metacpan
Qudo::Driver::Skinny::Row::Job metacpan
Qudo::Driver::Skinny::Row::JobStatus metacpan
Qudo::Driver::Skinny::Schema metacpan
Qudo::Hook metacpan
Qudo::Hook::Serialize::JSON metacpan
Qudo::Hook::Serialize::MessagePack metacpan
Qudo::Hook::Serialize::Storable metacpan
Qudo::Job Qudo job class metacpan
Qudo::Manager qudo manager class. metacpan
Qudo::Plugin metacpan
Qudo::Test metacpan
Qudo::Worker superclass for defining task behavior of Qudo's work metacpan

Other Files

Build.PL metacpan
Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
README.md metacpan
cpanfile metacpan