Say-Compat

Metadata

Analyzed metadata and errors of Say-Compat.

{
   "abstracts_in_pod" : {
      "Say::Compat" : "Backwards compatibility wrapper for say()"
   },
   "author" : "MSCHWERN",
   "buildfile_executable" : 0,
   "dir_lib" : "lib",
   "dir_t" : "t",
   "dirs_array" : [
      "lib",
      "lib/Say",
      "t"
   ],
   "dist" : "Say-Compat",
   "dynamic_config" : 1,
   "error" : {
      "valid_signature" : "WARNING: This key is not certified with a trusted signature!\nPrimary key fingerprint: 3669 19C5 3228 1283 6390  4112 58CA 2196 10F5 4327\n"
   },
   "extension" : "tar.gz",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_json" : "META.json",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_signature" : "SIGNATURE",
   "files_array" : [
      "META.json",
      "Makefile.PL",
      "META.yml",
      "SIGNATURE",
      "MANIFEST",
      "lib/Say/Compat.pm"
   ],
   "files_hash" : {
      "MANIFEST" : {
         "mtime" : 1354138935,
         "size" : 321
      },
      "META.json" : {
         "mtime" : 1354138935,
         "size" : 1234
      },
      "META.yml" : {
         "mtime" : 1354138935,
         "size" : 720
      },
      "Makefile.PL" : {
         "mtime" : 1354138849,
         "size" : 975,
         "used" : [
            "ExtUtils::MakeMaker"
         ]
      },
      "SIGNATURE" : {
         "mtime" : 1354138935,
         "size" : 1121
      },
      "lib/Say/Compat.pm" : {
         "module" : "Say::Compat",
         "mtime" : 1354138592,
         "noed" : [
            "strict"
         ],
         "required" : [
            "Perl6::Say",
            "feature"
         ],
         "size" : 1197,
         "used" : [
            "strict",
            "vars",
            "warnings"
         ]
      },
      "t/basic.t" : {
         "mtime" : 1354137663,
         "no_index" : 1,
         "size" : 97,
         "used" : [
            "Say::Compat",
            "strict",
            "warnings"
         ]
      }
   },
   "got_prereq_from" : "META.yml",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "distname_matches_name_in_meta" : 1,
      "easily_repackageable_by_debian" : 1,
      "easily_repackageable_by_fedora" : 1,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "fits_fedora_license" : 1,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 0,
      "has_human_readable_license" : 0,
      "has_known_license_in_source_file" : 0,
      "has_license_in_source_file" : 0,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 0,
      "has_separate_license_file" : 0,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 1,
      "kwalitee" : "86.36",
      "manifest_matches_dist" : 1,
      "meta_json_conforms_to_known_spec" : 1,
      "meta_json_is_parsable" : 1,
      "meta_yml_conforms_to_known_spec" : 1,
      "meta_yml_declares_perl_version" : 0,
      "meta_yml_has_license" : 1,
      "meta_yml_has_provides" : 0,
      "meta_yml_has_repository_resource" : 1,
      "meta_yml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 1,
      "valid_signature" : 1
   },
   "latest_mtime" : 1354138935,
   "license" : "perl defined in META.yml",
   "license_from_yaml" : "perl",
   "manifest_matches_dist" : 1,
   "meta_json_is_parsable" : 1,
   "meta_json_spec_version" : "2",
   "meta_yml" : {
      "abstract" : "Backwards compatibility wrapper for say()",
      "author" : [
         "Michael G Schwern <schwern@pobox.com>"
      ],
      "build_requires" : {
         "ExtUtils::MakeMaker" : "0"
      },
      "configure_requires" : {
         "ExtUtils::MakeMaker" : "0"
      },
      "dynamic_config" : "1",
      "generated_by" : "ExtUtils::MakeMaker version 6.62, CPAN::Meta::Converter version 2.120921",
      "license" : "perl",
      "meta-spec" : {
         "url" : "http://module-build.sourceforge.net/META-spec-v1.4.html",
         "version" : "1.4"
      },
      "name" : "Say-Compat",
      "no_index" : {
         "directory" : [
            "t",
            "inc"
         ]
      },
      "requires" : {
         "Perl6::Say" : "0.06"
      },
      "resources" : {
         "bugtracker" : "http://github.com/schwern/say-compat/issues/",
         "homepage" : "http://github.com/schwern/say-compat/",
         "license" : "http://dev.perl.org/licenses/",
         "repository" : "http://github.com/schwern/say-compat/"
      },
      "version" : "0.01"
   },
   "meta_yml_is_parsable" : 1,
   "meta_yml_spec_version" : "1.4",
   "modules" : [
      {
         "file" : "lib/Say/Compat.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "Say::Compat"
      }
   ],
   "no_index" : "^inc/;^t/",
   "no_pax_headers" : 1,
   "package" : "Say-Compat-0.01.tar.gz",
   "prereq" : [
      {
         "is_prereq" : 1,
         "requires" : "Perl6::Say",
         "type" : "runtime_requires",
         "version" : "0.06"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "ExtUtils::MakeMaker",
         "type" : "build_requires",
         "version" : "0"
      },
      {
         "requires" : "ExtUtils::MakeMaker",
         "type" : "configure_requires",
         "version" : "0"
      }
   ],
   "released_epoch" : 1354138962,
   "size_packed" : 2795,
   "size_unpacked" : 5665,
   "uses" : {
      "noed_in_code" : {
         "strict" : 1
      },
      "required_in_code" : {
         "Perl6::Say" : 1,
         "feature" : 1
      },
      "used_in_code" : {
         "strict" : 1,
         "vars" : 1,
         "warnings" : 1
      },
      "used_in_config" : {
         "ExtUtils::MakeMaker" : 1
      },
      "used_in_tests" : {
         "strict" : 1,
         "warnings" : 1
      }
   },
   "valid_signature" : 0,
   "version" : "0.01",
   "versions" : {
      "lib/Say/Compat.pm" : {
         "Say::Compat" : "0.01"
      }
   },
   "vname" : "Say-Compat-0.01"
}