Kwalitee Issues

meta_yml_conforms_to_known_spec

Take a look at the META.yml Spec at http://module-build.sourceforge.net/META-spec-v1.4.html (for version 1.4) or http://search.cpan.org/perldoc?CPAN::Meta::Spec (for version 2), and change your META.yml accordingly.

Error: '<undef>' for 'Carp' is not a valid version. (requires -> Carp) [Validation: 1.0];'<undef>' for 'Class::Accessor::Fast' is not a valid version. (requires -> Class::Accessor::Fast) [Validation: 1.0];'<undef>' for 'Data::UUID' is not a valid version. (requires -> Data::UUID) [Validation: 1.0];'<undef>' for 'POE::Component::Client::DNS' is not a valid version. (requires -> POE::Component::Client::DNS) [Validation: 1.0];'<undef>' for 'Scalar::Util' is not a valid version. (requires -> Scalar::Util) [Validation: 1.0];'<undef>' for 'Time::HiRes' is not a valid version. (requires -> Time::HiRes) [Validation: 1.0]

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: Sprocket::Connection

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.01,0.07

has_known_license_in_source_file

Add =head1 LICENSE and/or the proper text of the well-known license to the main module in your code.

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

no_invalid_versions

Fix the version numbers so that version::is_lax($version) returns true.

Error:

  • lib/Sprocket/Base.pm: HASH(0x7329648)

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Sprocket::Connection

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Sprocket A pluggable POE based Client / Server Library 0.07 metacpan
Sprocket::AIO IO::AIO support for Sprocket plugins metacpan
Sprocket::Base metacpan
Sprocket::ChannelManager metacpan
Sprocket::Client The Sprocket Client metacpan
Sprocket::Common metacpan
Sprocket::Connection Encapsulates a client or server connection metacpan
Sprocket::Event A wrapped event for Sprocket metacpan
Sprocket::Local metacpan
Sprocket::Local::Connection metacpan
Sprocket::Logger::Basic Basic logging for Sprocket metacpan
Sprocket::Logger::Log4perl metacpan
Sprocket::Plugin Base class for Sprocket plugins metacpan
Sprocket::Plugin::Manager metacpan
Sprocket::Server The Sprocket Server metacpan
Sprocket::Server::PreFork The PreForking Sprocket Server metacpan
Sprocket::Session 0.01 metacpan
Sprocket::Spread metacpan
Sprocket::Util::FDpasser Pass File Descripters using File::FDpasser metacpan
Sprocket::Util::Observable Helper class for the Sprocket event system metacpan

Provides

Name File View
Sprocket::AnonCallback lib/Sprocket.pm metacpan
Sprocket::Spread::Driver lib/Sprocket/Spread.pm metacpan
Sprocket::Spread::Filter lib/Sprocket/Spread.pm metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan