Kwalitee Issues

prereq_matches_use

List all used modules in META.yml requires

Error:

  • version

valid_signature

Sign the dist as the last step before creating the archive. Take care not to modify/regenerate dist meta files or the manifest.

Error: WARNING: This key is not certified with a trusted signature! Primary key fingerprint: 6E6E 3EF2 0B4E D0FF 2A09 D1C5 ABFE BFC1 BB50 CB19 --- SIGNATURE Mon Sep 26 14:37:41 2011 +++ (current) Mon Apr 25 08:55:59 2016 @@ -1,7 +1,8 @@ SHA1 663e1c1c7bd99a68b115354d488e9115687566a2 Build.PL SHA1 0827601f804545a67ad494412d5316f3818b7e16 Changes -SHA1 37423a0162695b1b322cf40eebdcc829de70b4ad MANIFEST -SHA1 c29cdc4594b7e2ac05ff92a8c0a23aa338c916ab META.yml +SHA1 d27781c9e9a3d0dcd6cb114e167841879ae9349a MANIFEST +SHA1 f82d806049f9533099a547a25cfc870619562a37 META.json +SHA1 6a7d0cf8521565d43955e92b926761e6db2b6f52 META.yml SHA1 64a60c636f0ea5d35f2efc47f8fa23f26f9da43b Makefile.PL SHA1 fba915edd13532ea9e579ea6fa142df6eb7e2eab README SHA1 dab6902a9cc46f44cf16e58969c5a9114cc0e04d ignore.txt ==> MISMATCHED content between SIGNATURE and distribution files! <==

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.094000,0.906000,1.005002004,1.007002007,1.007002010,1.008002004,1.009002007,1.010002005,1.010002007,1.011002005,1.014002007,1.036002005

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: TeX::AutoTeX, TeX::AutoTeX::ConcatPDF, TeX::AutoTeX::Config, TeX::AutoTeX::Exception, TeX::AutoTeX::File, TeX::AutoTeX::Fileset, TeX::AutoTeX::HyperTeX, TeX::AutoTeX::Log, TeX::AutoTeX::Mail, TeX::AutoTeX::PostScript, TeX::AutoTeX::Process, TeX::AutoTeX::StampPDF

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • strict
  • warnings

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
TeX::AutoTeX automated processing of (La-)TeX sources 0.906000 metacpan
TeX::AutoTeX::ConcatPDF concatenate a list of PDF files 0.094000 metacpan
TeX::AutoTeX::Config central configuration file for TeX::AutoTeX 1.007002010 metacpan
TeX::AutoTeX::Exception framework for exception handling in TeX::AutoTeX 1.007002007 metacpan
TeX::AutoTeX::File 1.036002005 metacpan
TeX::AutoTeX::Fileset 1.008002004 metacpan
TeX::AutoTeX::HyperTeX filter for augmenting TeX source with hypertex facilities 1.010002007 metacpan
TeX::AutoTeX::Log log handling for TeX::AutoTeX 1.010002005 metacpan
TeX::AutoTeX::Mail email handling for TeX::AutoTeX process messages 1.005002004 metacpan
TeX::AutoTeX::PostScript watermark PostScript files and related manipulations 1.011002005 metacpan
TeX::AutoTeX::Process orchestrate the system calls for tex, dvips, etc. 1.014002007 metacpan
TeX::AutoTeX::StampPDF watermark PDF files 1.009002007 metacpan

Provides

Name File View
TeX::AutoTeX::FatalException lib/TeX/AutoTeX/Exception.pm metacpan
TeX::AutoTeX::FormatException lib/TeX/AutoTeX/Exception.pm metacpan
TeX::AutoTeX::InvNameException lib/TeX/AutoTeX/Exception.pm metacpan
TeX::AutoTeX::MissfontException lib/TeX/AutoTeX/Exception.pm metacpan
TeX::AutoTeX::TexChrException lib/TeX/AutoTeX/Exception.pm metacpan
TeX::AutoTeX::TexMFCnfException lib/TeX/AutoTeX/Exception.pm metacpan
TeX::AutoTeX::TypeException lib/TeX/AutoTeX/Exception.pm metacpan
TeX::AutoTeX::WorkdirException lib/TeX/AutoTeX/Exception.pm metacpan

Other Files

Build.PL metacpan
Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan