Kwalitee Issues

has_readme

Add a README to the distribution. It should contain a quick description of your module and how to install it.

has_tests

Add tests!

meta_yml_conforms_to_known_spec

Take a look at the META.yml Spec at http://module-build.sourceforge.net/META-spec-v1.4.html (for version 1.4) or http://search.cpan.org/perldoc?CPAN::Meta::Spec (for version 2), and change your META.yml accordingly.

Error: 'mailto:scott@slowass.net' for 'bugtracker' does not have a URL authority (resources -> bugtracker) [Validation: 1.4]

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: Test-Float-0.3/lib/Test/Float/Results.pm -- Around line 82: =over without closing =back

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Benchmark
  • Config
  • Exporter
  • File::Spec
  • IO::Handle
  • strict
  • vars
  • warnings

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.01,0.02,0.26_01,0.3

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

has_tests_in_t_dir

Add tests or move tests.pl to the t/ directory!

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

no_unauthorized_packages

Ask the owner of the distribution (the one who released it first, or the one who is designated in x_authority) to give you a (co-)maintainer's permission.

Error:

  • Test::Float

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Test::Float::Assert, Test::Float::Iterator, Test::Float::Point, Test::Float::Results, Test::Float::Straps, Test::Float::Util

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

Modules

Name Abstract Version View
Test::Float Test::Harness modified to accept floating point test result values 0.3 metacpan
Test::Float::Assert simple assert 0.02 metacpan
Test::Float::Iterator Internal Test::Float Iterator 0.02 metacpan
Test::Float::Point object for tracking a single test point 0.01 metacpan
Test::Float::Results object for tracking results from a single test file 0.01 metacpan
Test::Float::Straps detailed analysis of test results 0.26_01 metacpan
Test::Float::Util Utility functions for Test::Float::* 0.01 metacpan

Provides

Name File View
Test::Float::Iterator::ARRAY lib/Test/Float/Iterator.pm metacpan
Test::Float::Iterator::FH lib/Test/Float/Iterator.pm metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan