Kwalitee Issues

has_changelog

Add a Changelog (best named 'Changes') to the distribution. It should list at least major changes implemented in newer versions.

has_proper_version

Remove all letters from the version number. If you want to mark a release as a developer release, use the scheme 'Module-1.00_01'

manifest_matches_dist

Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.

Error:

  • MANIFEST (135) does not match dist (71):
  • Missing in MANIFEST: Artistic, MANIFEST, Makefile.PL, README, UnixODBC.pm, UnixODBC.xs, UnixODBC/BridgeServer.pm, UnixODBC/DriverConf.pm, UnixODBC/RSS.pm, UnixODBC/RSS/Makefile.PL, UnixODBC/RSS/Ver10.pm, UnixODBC/RSS/t/use.t, UnixODBC/t/use.t, auto/UnixODBC/autosplit.ix, bridge/Makefile, bridge/Makefile.PL, bridge/odbcbridge, bridge/odbcbridge.conf, bridge/odbclogins, bridge/remotedsn, bridge/remotetables, bridge/sampleclient, bridge/unixodbc, datamanager/datamanager.cgi, datamanager/dsn.gif, datamanager/dsns.shtml, datamanager/index.html, datamanager/main.shtml, datamanager/odbc.gif, datamanager/odbclogin.cgi, datamanager/odbclogin.shtml, datamanager/odbclogins, datamanager/query.shtml, datamanager/table.gif, datamanager/tables.cgi, datamanager/tables.shtml, datamanager/term-no.gif, datamanager/terminal.gif, dbms/MySQLTest.ini, dbms/README, dbms/TestDrv.ini, dbms/files.dat, dbms/mysql.ins, dbms/postgres.ins, dbms/psqlODBC.ini, dbms/test.pl, dbms/titles.dat, dbms/unixODBCpsql.ini, eg/Makefile.PL, eg/alltypes, eg/apifuncs, eg/client, eg/colattributes, eg/connectinfo, eg/datasources, eg/driverinfo, eg/gutenberg.cgi, eg/installscripts, eg/rssoutput, eg/sqltables, odbctypes.h, sqltypes.h, t/use.t, tkdm/Makefile.PL, tkdm/README, tkdm/dot-odbclogins, tkdm/installscripts, tkdm/tkdm, typemap
  • Missing in Dist: ., ./Artistic, ./MANIFEST, ./Makefile.PL, ./README, ./UnixODBC, ./UnixODBC.pm, ./UnixODBC.xs, ./UnixODBC/BridgeServer.pm, ./UnixODBC/CVS, ./UnixODBC/CVS/Entries, ./UnixODBC/CVS/Entries.Log, ./UnixODBC/CVS/Repository, ./UnixODBC/CVS/Root, ./UnixODBC/DriverConf.pm, ./UnixODBC/RSS, ./UnixODBC/RSS.pm, ./UnixODBC/RSS/CVS, ./UnixODBC/RSS/CVS/Entries, ./UnixODBC/RSS/CVS/Entries.Log, ./UnixODBC/RSS/CVS/Repository, ./UnixODBC/RSS/CVS/Root, ./UnixODBC/RSS/Makefile.PL, ./UnixODBC/RSS/Ver10.pm, ./UnixODBC/RSS/t, ./UnixODBC/RSS/t/CVS, ./UnixODBC/RSS/t/CVS/Entries, ./UnixODBC/RSS/t/CVS/Repository, ./UnixODBC/RSS/t/CVS/Root, ./UnixODBC/RSS/t/use.t, ./UnixODBC/t, ./UnixODBC/t/CVS, ./UnixODBC/t/CVS/Entries, ./UnixODBC/t/CVS/Repository, ./UnixODBC/t/CVS/Root, ./UnixODBC/t/use.t, ./auto, ./auto/CVS, ./auto/CVS/Entries, ./auto/CVS/Entries.Log, ./auto/CVS/Repository, ./auto/CVS/Root, ./auto/UnixODBC, ./auto/UnixODBC/CVS, ./auto/UnixODBC/CVS/Entries, ./auto/UnixODBC/CVS/Repository, ./auto/UnixODBC/CVS/Root, ./auto/UnixODBC/autosplit.ix, ./bridge, ./bridge/CVS, ./bridge/CVS/Entries, ./bridge/CVS/Repository, ./bridge/CVS/Root, ./bridge/Makefile, ./bridge/Makefile.PL, ./bridge/odbcbridge, ./bridge/odbcbridge.conf, ./bridge/odbclogins, ./bridge/remotedsn, ./bridge/remotetables, ./bridge/sampleclient, ./bridge/unixodbc, ./datamanager, ./datamanager/CVS, ./datamanager/CVS/Entries, ./datamanager/CVS/Repository, ./datamanager/CVS/Root, ./datamanager/datamanager.cgi, ./datamanager/dsn.gif, ./datamanager/dsns.shtml, ./datamanager/index.html, ./datamanager/main.shtml, ./datamanager/odbc.gif, ./datamanager/odbclogin.cgi, ./datamanager/odbclogin.shtml, ./datamanager/odbclogins, ./datamanager/query.shtml, ./datamanager/table.gif, ./datamanager/tables.cgi, ./datamanager/tables.shtml, ./datamanager/term-no.gif, ./datamanager/terminal.gif, ./dbms, ./dbms/CVS, ./dbms/CVS/Entries, ./dbms/CVS/Repository, ./dbms/CVS/Root, ./dbms/MySQLTest.ini, ./dbms/README, ./dbms/TestDrv.ini, ./dbms/files.dat, ./dbms/mysql.ins, ./dbms/postgres.ins, ./dbms/psqlODBC.ini, ./dbms/test.pl, ./dbms/titles.dat, ./dbms/unixODBCpsql.ini, ./eg, ./eg/CVS, ./eg/CVS/Entries, ./eg/CVS/Repository, ./eg/CVS/Root, ./eg/Makefile.PL, ./eg/alltypes, ./eg/apifuncs, ./eg/client, ./eg/colattributes, ./eg/connectinfo, ./eg/datasources, ./eg/driverinfo, ./eg/gutenberg.cgi, ./eg/installscripts, ./eg/rssoutput, ./eg/sqltables, ./odbctypes.h, ./sqltypes.h, ./t, ./t/CVS, ./t/CVS/Entries, ./t/CVS/Repository, ./t/CVS/Root, ./t/use.t, ./tkdm, ./tkdm/CVS, ./tkdm/CVS/Entries, ./tkdm/CVS/Repository, ./tkdm/CVS/Root, ./tkdm/Makefile.PL, ./tkdm/README, ./tkdm/dot-odbclogins, ./tkdm/installscripts, ./tkdm/tkdm, ./typemap

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: UnixODBC-0.34/UnixODBC/DriverConf.pm -- Around line 345: Non-ASCII character seen before =encoding in '©'. Assuming CP1252 UnixODBC-0.34/UnixODBC/RSS.pm -- Around line 206: Non-ASCII character seen before =encoding in '©'. Assuming CP1252 UnixODBC-0.34/UnixODBC.pm-- Around line 4222: Non-ASCII character seen before =encoding in '©'. Assuming CP1252

package_version_matches_dist_version

Fix the version(s).

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: BridgeAPI, UnixODBC::DriverConf, UnixODBC::RSS, UnixODBC::RSS::Ver10

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.02,0.04,0.06,0.25,0.34

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: BridgeAPI, UnixODBC::DriverConf, UnixODBC::RSS, UnixODBC::RSS::Ver10

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
BridgeAPI 0.25 metacpan
UnixODBC Perl extension for unixODBC. 0.34 metacpan
UnixODBC::DriverConf Properties for UnixODBC drivers. 0.02 metacpan
UnixODBC::RSS 0.06 metacpan
UnixODBC::RSS::Ver10 0.04 metacpan

Provides

Name File View
UnixODBC::BridgeServer UnixODBC/BridgeServer.pm metacpan

Other Files

MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan
UnixODBC/RSS/Makefile.PL metacpan
bridge/Makefile.PL metacpan
eg/Makefile.PL metacpan
tkdm/Makefile.PL metacpan