Kwalitee Issues

prereq_matches_use

List all used modules in META.yml requires

Error:

  • URI::Escape
  • URI::file

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: WWW::PGXN, WWW::PGXN::Distribution, WWW::PGXN::Extension, WWW::PGXN::Mirror, WWW::PGXN::Tag, WWW::PGXN::User

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • URI::QueryParam

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

Modules

Name Abstract Version View
WWW::PGXN Interface to PGXN mirrors and the PGXN API v0.12.4 metacpan
WWW::PGXN::Distribution Distribution metadata fetched from PGXN v0.12.4 metacpan
WWW::PGXN::Extension Extension metadata fetched from PGXN v0.12.4 metacpan
WWW::PGXN::Mirror Mirror metadata fetched from PGXN v0.12.4 metacpan
WWW::PGXN::Tag Tag metadata fetched from PGXN v0.12.4 metacpan
WWW::PGXN::User User metadata fetched from PGXN v0.12.4 metacpan

Other Files

Build.PL metacpan
Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README.md metacpan
t/mirror/dist/pair/0.1.0/META.json metacpan
t/mirror/dist/pair/0.1.1/META.json metacpan
t/mirror/dist/pair/0.1.2/META.json metacpan