Kwalitee Issues


Add a Changelog (best named 'Changes') to the distribution. It should list at least major changes implemented in newer versions.


Add =head1 LICENSE and the text of the license to the main module in your code.


Add a META.yml to the distribution. Your buildtool should be able to autogenerate it.


Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.


  • MANIFEST (12) does not match dist (52):
  • Missing in MANIFEST: CREDITS, WeSQL-0.53-1.spec, addressbook/README, addressbook/conf/, addressbook/database/pg_recreate_tables.sql, addressbook/database/, addressbook/database/pg_startdata.sql, addressbook/database/recreate_tables.sql, addressbook/database/, addressbook/database/startdata.sql, addressbook/public_html/admin/cloak.wsql, addressbook/public_html/admin/, addressbook/public_html/admin/, addressbook/public_html/admin/index.wsql, addressbook/public_html/admin/, addressbook/public_html/admin/, addressbook/public_html/admin/, addressbook/public_html/admin/, addressbook/public_html/admin/, addressbook/public_html/admin/uncloak.wsql, addressbook/public_html/, addressbook/public_html/, addressbook/public_html/images/bel_flag.png, addressbook/public_html/images/gb_flag.png, addressbook/public_html/images/ned_flag.png, addressbook/public_html/images/usa_flag.png, addressbook/public_html/index.wsql, addressbook/public_html/, addressbook/public_html/, addressbook/public_html/, addressbook/public_html/, addressbook/public_html/, html/upgrade.html, lib/Apache/WeSQL/, lib/Apache/WeSQL/, utils/README, utils/, utils/, utils/, utils/


Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: WeSQL-0.53/lib/Apache/WeSQL/ -- Around line 892: You forgot a '=back' before '=head2'Around line 944: You forgot a '=back' before '=head2'Around line 948: '=item' outside of any '=over'Around line 1288: =back without =overAround line 1519: You forgot a '=back' before '=head1' WeSQL-0.53/lib/Apache/ -- Around line 871: Expected '=item *'


Remove the symlinks from the distribution.


List all used modules in META.yml requires


  • Apache::Constants


Add =head1 LICENSE and/or the proper text of the well-known license to the main module in your code.


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


Add tests or move to the t/ directory!


Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.


Name Abstract Version View
Apache::WeSQL Apache mod_perl module for WeSQL 0.53 metacpan
Apache::WeSQL::AppHandler Perl ApacheHandler for a WeSQL application 0.53 metacpan
Apache::WeSQL::Auth Auth subs for a journalled WeSQL application 0.53 metacpan
Apache::WeSQL::Display A library of functions to create web-pages based on a 'Journalled' SQL database. 0.53 metacpan
Apache::WeSQL::Journalled A library of functions to deal with an SQL database in a Journalled way. 0.53 metacpan
Apache::WeSQL::SqlFunc A library of functions to deal with the SQL database 0.53 metacpan

Other Files

MANIFEST metacpan
Makefile.PL metacpan
README metacpan