WebService-E4SE

Metadata

Analyzed metadata and errors of WebService-E4SE.

{
   "abstracts" : {
      "WebService::E4SE" : "Communicate with the various Epicor E4SE web services."
   },
   "author" : "CAPOEIRAB",
   "buildfile_executable" : 0,
   "dir_lib" : "lib",
   "dir_t" : "t",
   "dirs_array" : [
      "lib",
      "lib/WebService",
      "t"
   ],
   "dist" : "WebService-E4SE",
   "dynamic_config" : 1,
   "error" : {},
   "extension" : "tar.gz",
   "external_license_file" : "LICENSE",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_changelog" : "Changes",
   "file_license" : "LICENSE",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_json" : "META.json",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README.md",
   "files_array" : [
      "META.json",
      "Changes",
      "README.md",
      "Makefile.PL",
      "META.yml",
      "MANIFEST",
      "LICENSE",
      "lib/WebService/E4SE.pm"
   ],
   "files_hash" : {
      "Changes" : {
         "mtime" : 1396980795,
         "size" : 440
      },
      "LICENSE" : {
         "mtime" : 1377710495,
         "size" : 8645
      },
      "MANIFEST" : {
         "mtime" : 1397661579,
         "size" : 298
      },
      "META.json" : {
         "mtime" : 1397661579,
         "size" : 1815
      },
      "META.yml" : {
         "mtime" : 1397661576,
         "size" : 1063
      },
      "Makefile.PL" : {
         "mtime" : 1397658894,
         "size" : 1473,
         "used" : [
            "5.006",
            "ExtUtils::MakeMaker",
            "strict",
            "warnings"
         ]
      },
      "README.md" : {
         "mtime" : 1396980321,
         "size" : 2755
      },
      "lib/WebService/E4SE.pm" : {
         "license" : "Artistic_1_0,Artistic_2_0",
         "module" : "WebService::E4SE",
         "mtime" : 1397658894,
         "size" : 16366,
         "used" : [
            "5.006",
            "Authen::NTLM",
            "Carp",
            "HTTP::Headers",
            "HTTP::Request",
            "LWP::UserAgent",
            "Moose",
            "MooseX::Types::Moose",
            "URI",
            "XML::Compile::SOAP11",
            "XML::Compile::SOAP11::Client",
            "XML::Compile::Transport::SOAPHTTP",
            "XML::Compile::WSDL11",
            "XML::LibXML",
            "namespace::autoclean"
         ]
      },
      "t/00-load.t" : {
         "mtime" : 1396972682,
         "no_index" : 1,
         "size" : 1076,
         "used" : [
            "FindBin",
            "Test::More",
            "URI",
            "lib",
            "strict",
            "warnings"
         ]
      },
      "t/pod-coverage.t" : {
         "mtime" : 1397659524,
         "no_index" : 1,
         "size" : 205,
         "used" : [
            "Test::More",
            "Test::Pod::Coverage",
            "strict"
         ]
      },
      "t/pod.t" : {
         "mtime" : 1397659562,
         "no_index" : 1,
         "size" : 159,
         "used" : [
            "Test::More",
            "Test::Pod",
            "strict"
         ]
      }
   },
   "got_prereq_from" : "META.yml",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "easily_repackageable_by_debian" : 1,
      "easily_repackageable_by_fedora" : 1,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "fits_fedora_license" : 1,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 1,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 1,
      "kwalitee" : "100.00",
      "manifest_matches_dist" : 1,
      "metayml_conforms_to_known_spec" : 1,
      "metayml_declares_perl_version" : 1,
      "metayml_has_license" : 1,
      "metayml_has_provides" : 0,
      "metayml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 1,
      "valid_signature" : 1
   },
   "latest_mtime" : 1397661579,
   "license" : "artistic_2 defined in META.yml defined in LICENSE",
   "license_from_yaml" : "artistic_2",
   "license_in_pod" : 1,
   "licenses" : {
      "Artistic_1_0" : [
         "lib/WebService/E4SE.pm"
      ],
      "Artistic_2_0" : [
         "lib/WebService/E4SE.pm"
      ]
   },
   "manifest_matches_dist" : 1,
   "meta_yml" : {
      "abstract" : "Communicate with the various Epicor E4SE web services.",
      "author" : [
         "Chase Whitener <cwhitener@gmail.com>"
      ],
      "build_requires" : {
         "Test::More" : "0",
         "Test::Pod" : "0",
         "Test::Pod::Coverage" : "0"
      },
      "configure_requires" : {
         "ExtUtils::MakeMaker" : "0"
      },
      "dynamic_config" : "1",
      "generated_by" : "ExtUtils::MakeMaker version 6.84, CPAN::Meta::Converter version 2.133380",
      "license" : "artistic_2",
      "meta-spec" : {
         "url" : "http://module-build.sourceforge.net/META-spec-v1.4.html",
         "version" : "1.4"
      },
      "name" : "WebService-E4SE",
      "no_index" : {
         "directory" : [
            "t",
            "inc",
            "t"
         ]
      },
      "requires" : {
         "Authen::NTLM" : "1",
         "HTTP::Headers" : "6",
         "HTTP::Request" : "6",
         "LWP::UserAgent" : "6",
         "Moose" : "2",
         "MooseX::Types::Moose" : "0.2",
         "URI" : "1.6",
         "XML::Compile::SOAP" : "2.38",
         "XML::Compile::WSDL11" : "2.38",
         "XML::LibXML" : "1.94",
         "namespace::autoclean" : "0",
         "perl" : "5.010001"
      },
      "resources" : {
         "bugtracker" : "http://github.com/genio/webservice-e4se/issues",
         "homepage" : "http://cwhitener.com",
         "license" : "http://www.opensource.org/licenses/artistic-license-2.0",
         "repository" : "http://github.com/genio/webservice-e4se"
      },
      "version" : "0.021"
   },
   "metayml_is_parsable" : 1,
   "modules" : [
      {
         "file" : "lib/WebService/E4SE.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "WebService::E4SE"
      }
   ],
   "no_index" : "^inc/;^t/;^t/",
   "no_pax_headers" : 1,
   "package" : "WebService-E4SE-0.021.tar.gz",
   "prereq" : [
      {
         "is_prereq" : 1,
         "requires" : "LWP::UserAgent",
         "type" : "runtime_requires",
         "version" : "6"
      },
      {
         "is_prereq" : 1,
         "requires" : "HTTP::Headers",
         "type" : "runtime_requires",
         "version" : "6"
      },
      {
         "is_prereq" : 1,
         "requires" : "URI",
         "type" : "runtime_requires",
         "version" : "1.6"
      },
      {
         "is_prereq" : 1,
         "requires" : "XML::Compile::WSDL11",
         "type" : "runtime_requires",
         "version" : "2.38"
      },
      {
         "is_prereq" : 1,
         "requires" : "Moose",
         "type" : "runtime_requires",
         "version" : "2"
      },
      {
         "is_prereq" : 1,
         "requires" : "XML::Compile::SOAP",
         "type" : "runtime_requires",
         "version" : "2.38"
      },
      {
         "is_prereq" : 1,
         "requires" : "Authen::NTLM",
         "type" : "runtime_requires",
         "version" : "1"
      },
      {
         "is_prereq" : 1,
         "requires" : "HTTP::Request",
         "type" : "runtime_requires",
         "version" : "6"
      },
      {
         "is_prereq" : 1,
         "requires" : "XML::LibXML",
         "type" : "runtime_requires",
         "version" : "1.94"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Test::Pod",
         "type" : "build_requires",
         "version" : "0"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Test::Pod::Coverage",
         "type" : "build_requires",
         "version" : "0"
      },
      {
         "requires" : "ExtUtils::MakeMaker",
         "type" : "configure_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "perl",
         "type" : "runtime_requires",
         "version" : "5.010001"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Test::More",
         "type" : "build_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "MooseX::Types::Moose",
         "type" : "runtime_requires",
         "version" : "0.2"
      },
      {
         "is_prereq" : 1,
         "requires" : "namespace::autoclean",
         "type" : "runtime_requires",
         "version" : "0"
      }
   ],
   "released_epoch" : 1397661964,
   "size_packed" : 10988,
   "size_unpacked" : 34295,
   "uses" : {
      "used_in_code" : {
         "5.006" : 1,
         "Authen::NTLM" : 1,
         "Carp" : 1,
         "HTTP::Headers" : 1,
         "HTTP::Request" : 1,
         "LWP::UserAgent" : 1,
         "Moose" : 1,
         "MooseX::Types::Moose" : 1,
         "URI" : 1,
         "XML::Compile::SOAP11" : 1,
         "XML::Compile::SOAP11::Client" : 1,
         "XML::Compile::Transport::SOAPHTTP" : 1,
         "XML::Compile::WSDL11" : 1,
         "XML::LibXML" : 1,
         "namespace::autoclean" : 1
      },
      "used_in_config" : {
         "5.006" : 1,
         "ExtUtils::MakeMaker" : 1,
         "strict" : 1,
         "warnings" : 1
      },
      "used_in_tests" : {
         "FindBin" : 1,
         "Test::More" : 3,
         "Test::Pod" : 1,
         "Test::Pod::Coverage" : 1,
         "URI" : 1,
         "lib" : 1,
         "strict" : 3,
         "warnings" : 1
      }
   },
   "valid_signature" : -1,
   "version" : "0.021",
   "versions" : {
      "lib/WebService/E4SE.pm" : {
         "WebService::E4SE" : "0.021"
      }
   },
   "vname" : "WebService-E4SE-0.021"
}