smokebrew

Prerequisites

smokebrew declares the following 27 modules as prerequisites.

Listed PrerequisitesRequired VersionLatest DistKwalitee
Archive::Extract0.40Archive-Extract-0.72128.13
CPAN::Perl::Releases0.02CPAN-Perl-Releases-1.76137.50
Config::INI::Reader0.014Config-INI-0.024134.38
Devel::PatchPerl0.24Devel-PatchPerl-1.24137.50
File::Fetch0.24File-Fetch-0.48131.25
File::Path2.08File-Path-2.09131.25
File::Spec3.31PathTools-3.47125.00
File::pushd1.00File-pushd-1.009137.50
IPC::Cmd0.58IPC-Cmd-0.92131.25
List::MoreUtils0.22List-MoreUtils-0.33131.25
Log::Message::Simple0.06Log-Message-Simple-0.10121.88
Module::CoreList2.49Module-CoreList-5.021001131.25
Module::Load::Conditional0.38Module-Load-Conditional-0.62131.25
Module::Pluggable3.9Module-Pluggable-5.1118.75
Moose1.03Moose-2.1210137.50
Moose::Role1.03Moose-2.1210137.50
Moose::Util::TypeConstraints1.03Moose-2.1210137.50
MooseX::ConfigFromFile0.02MooseX-ConfigFromFile-0.13137.50
MooseX::Getopt0.27MooseX-Getopt-0.63137.50
MooseX::Types::Email0.003MooseX-Types-Email-0.006137.50
MooseX::Types::Moose0.21MooseX-Types-0.44137.50
MooseX::Types::Path::Class0.05MooseX-Types-Path-Class-0.06134.38
MooseX::Types::URI0.03MooseX-Types-URI-0.07137.50
Parse::CPAN::Meta1.40Parse-CPAN-Meta-1.4414134.38
Perl::Version1.009Perl-Version-1.013134.38
URI1.54URI-1.61128.13
perl5.006perl0.00

smokebrew declares the following 4 modules as build prerequisites.

Listed Build PrerequisitesRequired VersionLatest DistKwalitee
File::Spec3.31PathTools-3.47125.00
IO::Handle0IO-1.25128.13
IPC::Open30perl0.00
Test::More0Test-Simple-1.001003131.25

smokebrew declares the following 1 modules as optional prerequisites.

Listed Optional PrerequisitesRequired VersionLatest DistKwalitee
ExtUtils::MakeMaker6.30ExtUtils-MakeMaker-6.98134.375